UtgÄvan av DNS-servern BIND 9.20.0, översatt till libuv och en ny backend för databasen

Efter tvÄ och ett halvt Ärs utveckling har konsortiet ISC presenterat den första stabila versionen av den nya betydande grenen av DNS-servern BIND 9.20, som har inkluderat Àndringar som har utvecklats i den experimentella grenen BIND 9.19. Stödet för grenen 9.20 kommer att ges inom ramen för ett utökat underhÄllscykel fram till första kvartalet 2028. Stödet för grenen 9.18 upphör under andra kvartalet 2025. För att utveckla funktionaliteten i nÀsta stabila version av BIND kommer en experimentell gren, BIND 9.21.0, att skapas. Projektets kod Àr skriven i C och distribueras under licensen MPL 2.0.

Huvudsakliga förÀndringar:

  • KĂ€rnan i applikationen, som kopplar ihop alla komponenter, har översatts till att anvĂ€nda en hĂ€ndelsehanteringscykel i icke-blockerande lĂ€ge, implementerad med hjĂ€lp av biblioteket libuv, som anvĂ€nds i projekt som Node.js, Knot DNS, H2O, Luvit och MoarVM. I grenen 9.16 har nĂ€tverksanslutningshanteraren i BIND översatts till libuv, och nu Ă€ven delar som anvĂ€nds för att interagera med interna komponenter i infrastrukturen, samt lĂ„ngvariga uppgifter i separata trĂ„dar, hjĂ€lpprocesser (threadpool) som anvĂ€nds för att verifiera DNSSEC, zonöverföringar, underhĂ„lla zonkataloger och hantera RPZ (Response Policy Zone). För att bygga BIND krĂ€vs nu minst version 1.34.0 av libuv.
  • En ny backend för databasarbete har föreslagits — "QP trie", som ersĂ€tter RBTDB (Red-Black Tree Database) och anvĂ€nds som standard för lagring av cache och DNS-zon databaser. För flertrĂ„dad verksamhet i QP trie anvĂ€nder man biblioteket liburcu med implementeringar i anvĂ€ndarutrymmet av strukturer som inte anvĂ€nder lĂ„s, tack vare bruket av RCU (read-copy-update) synkroniseringsmekanismen och QSBR (Quiescent-State-Based Reclamation) metoden för sĂ€ker minneshantering.
  • Den uppdaterade komprimeringsmetoden har anvĂ€nts domĂ€nnamn, vilket anvĂ€nder en mer kompakt kodningsmetod för namn med ett stort antal etiketter.
  • Möjligheterna för DNSSEC har utökats: "dnssec-policy" fĂ„r anvĂ€ndas för att hantera signerade zoner (auto-dnssec-alternativet har tagits bort); vid anvĂ€ndning av "inline-signing" har stödet för RFC 8901 (DNSSEC multi-signer model 2) lagts till; stödet för PKCS#11 baserat pĂ„ OpenSSL 3.0.0 Engine API har Ă„terinförts; i "dnssec-policy" har stöd för HSM (Hardware Security Module) lagts till.
  • Stöd för den andra versionen av zonekatalogen (Catalog Zone, RFC 9432) har lagts till, vilket förenklar hanteringen av sekundĂ€ra DNS-servrar genom att istĂ€llet för att definiera enskilda poster för varje sekundĂ€r zon pĂ„ den sekundĂ€ra servern, möjliggör en överföring av katalogen av sekundĂ€ra zoner mellan den primĂ€ra och den sekundĂ€ra servern. Efter att ha konfigurerat överföringen av katalogen pĂ„ samma sĂ€tt som enskilda zoner, skapas de zoner som lĂ€ggs till pĂ„ den primĂ€ra servern och som Ă€r markerade som ingĂ„ende i katalogen automatiskt pĂ„ den sekundĂ€ra servern utan behov av att redigera konfigurationsfiler.
  • Stöd för mekanismen för utökade fel (Extended DNS Errors, RFC 8914) har lagts till, vilket gör det möjligt att returnera ytterligare information om orsaken till ett fel som uppstĂ„tt vid utförandet av en DNS-förfrĂ„gan.
  • Genomförandet av teknologierna "DNS över HTTPS" (DoH, DNS over HTTPS) och DNS över TLS (DoT, DNS over TLS), som anvĂ€nds för att kryptera kundernas förfrĂ„gningar till resolvern och krypterad datautbyte mellan servrar, har övergĂ„tt till anvĂ€ndning av en enhetlig transport.
  • Möjligheten att anvĂ€nda PROXYv2-protokollet med alla transportlösningar som stöds av BIND har lagts till. PROXY-protokollet tillĂ„ter överföring av anslutningsinformation för att bevara information om den ursprungliga IP-adressen och portnumret vid vid vidarebefordran av DNS-förfrĂ„gningar genom andra backend-lösningar, lastbalanserare och proxyer.servrar.
  • Stöd för USDT-lĂ€get (User Statically Defined Tracing) har lagts till, vilket gör det möjligt att utföra applikationstracering med hjĂ€lp av kommandot perf, utan att skapa ytterligare overhead nĂ€r spĂ„rning Ă€r avstĂ€ngd.
  • Den insamlade statistiken speglar information om ofullstĂ€ndiga inkommande zonöverföringsoperationer.
  • Arbete har utförts för att minska fördröjningar, sĂ€nka minnesanvĂ€ndningen och avlasta CPU:n vid namnupplösning, anvĂ€ndning av DNS-over-TLS och generering av svar via UDP och TCP.
    UtgÄvan av DNS-servern BIND 9.20.0, översatt till libuv och en ny backend för databasen
    UtgÄvan av DNS-servern BIND 9.20.0, översatt till libuv och en ny backend för databasen
    UtgÄvan av DNS-servern BIND 9.20.0, översatt till libuv och en ny backend för databasen

KĂ€lla: opennet.ru

Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar đŸ”„ Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar | ProHoster