Det finns en Äsikt: DANE-teknologin för webblÀsare har misslyckats

Vi pratar om vad DANE-teknologin för autentisering av domÀnnamn via DNS innebÀr och varför den inte har fÄtt ett brett genomslag i webblÀsare.

Det finns en Äsikt: DANE-teknologin för webblÀsare har misslyckats
/ Unsplash / Paulius Dragunas

Vad Àr DANE

Certifieringsorgan (CA) Ă€r organisationer som med certifikat av kryptografiska SSL-certifikat. De sĂ€tter sin elektroniska signatur pĂ„ dem för att bekrĂ€fta Ă€ktheten. Men ibland uppstĂ„r situationer dĂ€r certifikat utfĂ€rdas pĂ„ otillĂ„tna sĂ€tt. Till exempel inledde Google förra Ă„ret en "Ă„tgĂ€rd för att Ă„terkalla förtroendet" för Symantecs certifikat pĂ„ grund av deras kompromettering (denna historia belyste vi pĂ„ vĂ„r blogg — ett och tvĂ„).

För att undvika sĂ„dana situationer började IETF för flera Ă„r sedan utveckla DANE-teknologin (men den har inte fĂ„tt ett brett genomslag i webblĂ€sare — varför det blev sĂ„ ska vi diskutera senare).

DANE (DNS-baserad autentisering av namngivna enheter) Àr en uppsÀttning specifikationer som möjliggör anvÀndning av DNSSEC (Namn System Security Extensions) för att verifiera Àktheten av SSL-certifikat. DNSSEC Àr en utvidgning för domÀnnamnssystemet som minimerar attacker relaterade till adresstrukturering. Genom att anvÀnda dessa tvÄ teknologier kan webbansvarig eller klient kontakta en av DNS-zonoperatörerna för att bekrÀfta giltigheten av det anvÀnda certifikatet.

I grund och botten fungerar DANE som ett sjÀlvsignerat certifikat (garanten för dess pÄlitlighet Àr DNSSEC) och kompletterar CA:s funktioner.

Hur det fungerar

DANE-specifikationen beskrivs i RFC6698. Enligt dokumentet har en ny typ av resurspost i DNS-resursposter lagts till — TLSA. Den innehĂ„ller information om det certifikat som överförs, dimension och typ av de överförda uppgifterna, samt sjĂ€lva uppgifterna. Webbansvarig skapar ett digitalt fingeravtryck av certifikatet, signerar det med hjĂ€lp av DNSSEC och lĂ€gger ut det i TLSA.

Klienten ansluter sig till webbplatsen pÄ internet och jÀmför dess certifikat med "kopian" som mottagits frÄn DNS-operatören. Om de matchar betraktas resurserna som betrodda.

PÄ wiki-sidan om DANE ges följande exempel pÄ DNS-förfrÄgan till servern example.org pÄ TCP-port 443:

IN TLSA _443._tcp.example.org

Svaret ser ut sÄ hÀr:

 _443._tcp.example.com. IN TLSA (
   3 0 0 30820307308201efa003020102020... )

DANE har flera utvidgningar som fungerar med andra DNS-poster Àn TLSA. Den första Àr DNS-posten SSHFP för att verifiera nycklar vid SSH-anslutningar. Den beskrivs i RFC4255, RFC6594 och RFC7479. Det andra Àr en OPENPGPKEY-post för utbyte av nycklar med hjÀlp av PGP (RFC7929). Slutligen Àr den tredje en SMIMEA-post (i RFC-dokumentet Àr standarden inte formulerad, det finns bara ett utkast) för kryptografiskt nyckelutbyte via S/MIME.

Vad Àr problemet med DANE?

I mitten av maj hölls en DNS-OARC-konferens (detta Àr en ideell organisation som sysslar med frÄgor rörande sÀkerhet, stabilitet och utveckling av domÀnsystemet). PÄ ett av panelerna kom experterna fram till slutsatsen, att DANE-teknologin har misslyckats i webblÀsare (Ätminstone i den nuvarande implementeringen). Geoff Huston, en ledande forskare APNIC, en av fem regionala internetregistratorer, kommentarer om DANE som "en död teknologi".

PopulÀra webblÀsare stöder inte certifikatsautentisering med hjÀlp av DANE. PÄ marknaden finns specifika plugins, som avtÀcker funktionaliteten hos TLSA-poster, men Àven deras stöd upphör gradvis.

Problemen med spridningen av DANE i webblÀsare kopplas till den lÄngvariga valideringsprocessen via DNSSEC. Systemet tvingas utföra kryptografiska berÀkningar för att bekrÀfta Àktheten av SSL-certifikatet och gÄ igenom hela kedjan av DNS-servrar (frÄn rotzonen till vÀrddomen) vid första anslutningen till resursen.

Det finns en Äsikt: DANE-teknologin för webblÀsare har misslyckats
/ Unsplash / Kaley Dykstra

Denna brist försökte Mozilla ÄtgÀrda med hjÀlp av mekanismen DNSSEC Chain Extension för TLS. Den skulle minska antalet DNS-poster som klienten behövde granska under autentiseringen. Men inom utvecklargruppen uppstod oenigheter som inte kunde lösas. I slutÀndan övergavs projektet, Àven om det godkÀndes av IETF i mars 2018.

En annan orsak till den lĂ„ga populariteten för DANE anses vara den svaga spridningen av DNSSEC i vĂ€rlden — som bara fungerar med 19% av resurserna.. Experter bedömde att detta inte Ă€r tillrĂ€ckligt för att aktivt frĂ€mja DANE.

Troligtvis kommer industrin att utvecklas i en annan riktning. IstÀllet för att anvÀnda DNS för att verifiera SSL/TLS-certifikat, kommer marknadsaktörerna istÀllet att föresprÄka protokollen DNS-over-TLS (DoT) och DNS-over-HTTPS (DoH). Det senare nÀmnde vi i en av vÄra tidigare artiklar. pÄ Habré. De krypterar och verifierar anvÀndarnas förfrÄgningar till DNS-servern, vilket förhindrar angripare frÄn att manipulera data. I början av Äret var DoT redan integration med Mastodon, vilket orsakade blandade reaktioner frÄn anvÀndarna. Lyckligtvis Àr det, precis som det bör vara i öppen kÀllkod, valfritt och hanteras pÄ serveradministratörens sida. i Google för sin offentliga DNS. NÀr det kommer till DANE - om teknologin kommer att "ÄterfÄ greppet" och bli mainstream, ÄterstÄr att se i framtiden.

Vad mer har vi för ytterligare lÀsning:

Det finns en Ă„sikt: DANE-teknologin för webblĂ€sare har misslyckats SĂ„ hĂ€r automatiserar du hanteringen av IT-infrastrukturen – vi diskuterar tre trender
Det finns en Äsikt: DANE-teknologin för webblÀsare har misslyckats Hur fungerar ett datacenter och vad krÀvs för dess drift?

Det finns en Äsikt: DANE-teknologin för webblÀsare har misslyckats Hur man sparar pengar med hjÀlp av ett programgrÀnssnitt
Det finns en Äsikt: DANE-teknologin för webblÀsare har misslyckats DevOps i molntjÀnsten med exempel frÄn 1cloud.ru
Det finns en Äsikt: DANE-teknologin för webblÀsare har misslyckats Utvecklingen av molnarkitektur 1cloud

Det finns en Äsikt: DANE-teknologin för webblÀsare har misslyckats Hur teknisk support fungerar pÄ 1cloud
Det finns en Äsikt: DANE-teknologin för webblÀsare har misslyckats Myter om molnteknologier

KĂ€lla: habr.com

Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar đŸ”„ Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar | ProHoster