Werner Koch, huvudutvecklare och skapare av GnuPG (GNU Privacy Guard), grundade projektet LibrePGP, som fokuserar pÄ att utveckla en uppdaterad specifikation som Àr ett alternativ till standarden OpenPGP. Gaffeln skapades som svar pÄ de förÀndringar som föreslagits av IETF:s arbetsgrupp för att inkluderas i nÀsta uppdatering av specifikationen OpenPGP (RFC-4880) och som Koch uppfattade som tvivelaktiga ur ett perspektiv av att bevara kompatibilitet och sÀkerhet. Utvecklare av projekten GnuPG, RNP (implementering av OpenPGP frÄn Thunderbird) och Gpg4win som stödde gaffeln fruktar att de föreslagna Àndringarna kan bli skadliga för befintliga implementeringar av applikationer baserade pÄ OpenPGP, vars anvÀndare förvÀntar sig stabilitet i specifikationen pÄ lÄng sikt och inte Àr beredda att acceptera förÀndringar som bryter kompatibiliteten.
LibrePGP inkluderar nyttiga förbÀttringar som har utvecklats under de senaste Ären för en framtida version av specifikationen OpenPGP, men utesluter förÀndringar som negativt pÄverkar kompatibiliteten. Till exempel, jÀmfört med den aktuella standarden RFC-4880, har följande funktioner antagits i LibrePGP:
- Stöd för krypteringsalgoritmen Camellia (RFC-5581),
- Utvidgningar av ECC (Elliptic Curve Cryptography) för OpenPGP (RFC-6637).
- Obligatoriskt stöd för hash-algoritmer SHA2-256 (SHA-1 och MD5 har klassificerats som icke-rekommenderade, och möjligheten att avkoda data utan att verifiera integriteten har klassificerats som helt förÄldrad).
- Ăkning av storleken pĂ„ kontrollfingeravtrycket (fingerprint) till 256 bitar.
- Stöd för digital signatur schema EdDSA och elliptiska kurvor BrainpoolP256r1, BrainpoolP384r1, BrainpoolP512r1, Ed25519, Curve25519, Ed488 och X448.
- Stöd för algoritmen CRYSTALS-Kyber, kvantresistent mot brute force-attacker.
- Stöd för autentiserad kryptering i OCB-lÀget (Offset codebook mode).
- Implementering av den femte versionen av formatet för digitala signaturer med metadata-skydd.
- Stöd för avancerade subpaket med digitala signaturer.
Huvudpunkterna i kritiken mot den nya specifikationen i OpenPGP:
- IETF:s arbetsgrupp försökte istÀllet för en gradvis inkrementell uppdatering av specifikationen Äteruppfinna standarden och införa betydande förÀndringar som bryter kompatibiliteten.
- Införande av stöd för symmetrisk krypteringslÀge GCM (Galois/Counter Mode), som Àr svÄrt att implementera korrekt, samtidigt som OCB-lÀget (Offset Codebook Mode) ignoreras, vars patent löpte ut för flera Är sedan.
- TillÀgg av valfria paket med slumpmÀssig padding för att skydda mot trafikanalys. Enligt skaparna av LibrePGP utgör sÄdana paket med okontrollerad slumpmÀssig padding ett hot om att de kan anvÀndas för att skapa dolda kommunikationskanaler och kringgÄ datalÀckagepreventiva system. Tidigare avfÀrdades idén att inkludera padding, dÄ det ansÄgs vara en frÄga pÄ applikationsnivÄ snarare Àn krypteringsnivÄ.
- AnvÀndning av en modifierad ECDH-krypteringsschema (Àndrad OID-format), istÀllet för att anvÀnda den redan beskrivna i RFC-6637 och implementerade i PGP och GnuPG.
- Borttagning av vissa anvÀndbara funktioner, sÄsom den klassiska metoden för Äterkallande av nycklar, flaggan "m" för att markera MIME-data och flaggan "t" för att separera textdata frÄn binÀr data (flaggan "u" för text i UTF-8-kodning har introducerats istÀllet för flaggan "t").
- Avslag pÄ att inkludera metadata-skydd för den signerade filens nya format (till exempel kan filnamnet Àndras utan att bryta signaturen).
- Doubtful possibility to add "salt" to signatures (Salted signature) to enhance protection against prefix collision attacks. The salted value can be used as a non-disconnectable hidden channel to transmit 32 bytes of data in the signature.
- Flytt av standarden mot huvudsyftet för onlinekommunikation, vilket ignorerar behovet av lÄngsiktig datalagring.
Stödet för OpenPGP har redan publicerat en kritik av kritiken. Om inget kompromiss kan nÄs kan splittringen leda till ökande inkompatibiliteter i implementationerna av OpenPGP/LibrePGP. Delvis för att lösa detta problem har utvecklarna av OpenPGP faststÀllt den femte versionen av signaturformatet i en version som Àr kompatibel med LibrePGP och har gÄtt vidare med arbetet med sjÀtte versionen.
KĂ€lla: opennet.ru
