E-postservern Postfix 3.10.0 offentliggjord

Efter nĂ€stan ett Ă„rs utveckling har den nya stabila versionen av mailservern Postfix – 3.10.0 – publicerats. Samtidigt har det tillkĂ€nnagivits att stödet för Postfix 3.6, som slĂ€pptes i början av 2021, har upphört. Projektets kod Ă€r skriven i C och sprids under licenserna EPL 2.0 (Eclipse Public License) och IPL 1.0 (IBM Public License).

Postfix Àr ett av de fÄ projekten som kombinerar hög sÀkerhet, pÄlitlighet och prestanda, vilket har uppnÄtts tack vare en multiprocess-arkitektur som isolerar enskilda behandlare, samt en strikt kodstandard och patchaudit. För att skydda mot minnesfel anvÀnds sÀkrade varianter av funktioner för minnesallokering och frigöring, samt ett antal abstrakta inbÀddningsfunktioner för att hantera buffertar (kontrollerar buffertöverskridningar och tillgÄng till frigjord minne), filoperationer, utdataformatering, buffrad in-/utdata och strÀngmanipulationer (inklusive möjligheter för att arbeta med strÀngar av godtycklig storlek och automatisk storleksÀndring av strÀngar).

Enligt en automatiserad undersökning i februari anvĂ€nds cirka 550 000 e-postservrar, servrarPostfix anvĂ€nds pĂ„ 37,64 % (för ett Ă„r sedan 36,81 %) av e-postservrar, andelen Exim Ă€r 56,03 % (för ett Ă„r sedan 56,61 %), Sendmail – 3,39 % (3,60 %), MailEnable – 1,80 % (1,82 %), MDaemon – 0,39 % (0,40 %), Microsoft Exchange – 0,19 % (0,19 %), OpenSMTPD – 0,10 % (0,09 %).

E-postservern Postfix 3.10.0 offentliggjord

Huvudsakliga nyheter:

  • Möjligheten att anvĂ€nda kryptovalutor i TLS-algoritmer som Ă€r motstĂ„ndskraftiga mot kvantdatorattacker har lagts till. För att anvĂ€nda dessa algoritmer krĂ€vs versionen av OpenSSL-biblioteket 3.5, som fortfarande Ă€r under utveckling. För att vĂ€lja postkvant-algoritmer i Postfix har ingen ny syntax för TLS-grupper införts, utan man har förlitat sig pĂ„ instĂ€llningarna i OpenSSL, som kommer att anvĂ€ndas vid instĂ€llningarna för 'tls_eecdh_auto_curves' och 'tls_ffdhe_auto_groups' med tomma vĂ€rden.
  • Stöd för meddelandehuvudet 'TLS-Required: no' (RFC 8689) har lagts till, vilket innebĂ€r att leverans kommer att genomföras Ă€ven om den instĂ€llda TLS-sĂ€kerhetspolicyn inte kan upprĂ€tthĂ„llas. Med detta meddelandehuvud fungerar SMTP-klienten i lĂ€ge 'smtp_tls_security_level = may', dvs. den kontrollerar inte certifikatet. servern och kan gĂ„ tillbaka till en anslutning med klartextöverföring. I den nĂ€sta stora versionen av Postfix planerar vi att implementera SMTP-tillĂ€gget REQUIRETLS.
  • Stöd för protokollet TLS-RPT (Transport Layer Security Reporting) har lagts till, vilket gör det möjligt att spĂ„ra fel vid meddelandeleverans som kan uppstĂ„ om en krypterad anslutning, föreskriven av anvĂ€ndningen av DANE (DNS-baserad autentisering av namngivna enheter) eller MTA-STS (MTA Strict Transport Security), inte kan upprĂ€ttas. Ägaren av e-postdomen definierar DNS-parametrarna för TLS-RPT, varefter e-postservrarna kommer att skicka rapporter med information om lyckade och misslyckade TLS-anslutningar till MX-servrarna som hanterar domen. Implementeringen Ă€r baserad pĂ„ biblioteket libtlsrpt.
  • InstĂ€llningen "smtpd_hide_client_session = yes" har lagts till, vilket deaktiverar insĂ€ttning av information om klientens session nĂ€r SMTP-servern infogar headern "Received:". Exempel pĂ„ en avkortad header: "Received: by mail.example.com (Postfix) id postfix-queue-id för <user@example.com>; Dag, dd mĂ„n yyyy hh:mm:ss tz-offset (zon)".
  • Möjligheten till MIME-kodning (RFC 2047) av namn i de genererade Postfix-headerna "From:", som innehĂ„ller icke-ASCII-tecken, har lagts till. Den föreslagna kodningsschemat gör det möjligt att undvika att anvĂ€nda SMTPUTF8-tillĂ€gget (RFC 6531), som inte stöds av alla applikationer. Resultatet av MIME-kodningen ser ut som ‘"=?charset?Q?gibberish?=:’. För att avgöra den ursprungliga kodningen av namn har parameter "full_name_encoding_charset" lagts till, som som standard stĂ€lls in pĂ„ utf8.
  • Logiken för att hantera misslyckade anslutningar har Ă€ndrats nĂ€r endast en server anges i instĂ€llningarna "mysql:" eller "pgsql:". En sĂ„dan server uppfattas nu som en belastningsbalanserare och vid ett misslyckande skickas en ny begĂ€ran omedelbart, utan försening pĂ„ 60 sekunder.
  • I Milter har registrering av information om orsaken till att ett meddelande sĂ€tts i karantĂ€n lagts till.
  • I SMTP-servern har utdata i loggen med kö-ID eller vĂ€rdet "NOQUEUE" sĂ€kerstĂ€llts vid avslutning av anslutningen pĂ„ grund av timeout, avbrutning eller överskridande av felgrĂ€nsen. StĂ€dupprocessen ger i loggen "queueid: canceled" för meddelanden med en startad men inte avslutad transaktion.
  • I klienten Dovecot SASL anges i loggmeddelandena "Ogiltig autentiseringsteknik" nu specificeras den autentiseringsteknik som inte kunde anvĂ€ndas. SMTP-servern vid loggning av 'reject'-poster visar nu vĂ€rdena för instĂ€llningarna sasl_method, sasl_username och sasl_sender.
  • PĂ„ grund av förĂ€ndringen av det interna protokollet som anvĂ€nds av leveransagenter, krĂ€vs en omstart med kommandot "postfix reload" eller kommandona "postfix stop" och "postfix start" efter en uppdatering av Postfix-versionen. Annars kommer ett varningsmeddelande att visas i loggen "ovĂ€ntad attribut smtputf8 frĂ„n xxx socket (förvĂ€ntar: sendopts)".

KĂ€lla: opennet.ru

Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar đŸ”„ Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar | ProHoster