Den första stabila releasen av projektet nghttp3 Àr tillgÀnglig, som utvecklar ett bibliotek pÄ C-sprÄket med en implementering av HTTP/3-protokollet. En version av biblioteket för HTTP/2-protokollet, utvecklad av samma projekt, anvÀnds som grund för modulen mod_http2, som ingÄr i Apache http-servern. Projektets resultat anvÀnds ocksÄ i verktyget Curl. Koden för biblioteket distribueras under MIT-licensen.
HTTP/3-standarden definierar anvÀndningen av QUIC-protokollet (Quick UDP Internet Connections) som transport för HTTP/2. QUIC Àr en överbyggnad ovanpÄ UDP-protokollet som stöder multiplexering av flera anslutningar och tillhandahÄller krypteringsmetoder som motsvarar TLS/SSL. Protokollet skapades Är 2013 av Google som ett alternativ till TCP+TLS för webben, vilket löser problem med lÄng tid för anslutningsetablering och överenskommelse i TCP och eliminerar fördröjningar vid paketförlust under dataöverföring.
I nghttp3 finns en oberoende implementation av specifikationerna RFC 9114 (HTTP/3 över QUIC-protokollet), RFC 920 (komprimeringsteknik för headers, QPACK), RFC 9220 (WebSockets över HTTP/3) och RFC 9218 (utbyggbar schema för prioritering av svar pĂ„ klientens förfrĂ„gningar). Biblioteket Ă€r oberoende av specifika QUIC-stacks och stöder drift över olika implementationer av transportprotokollet QUIC. Samtidigt utvecklas en egen implementation av QUIC-protokollet av projektet â ngtcp2, som anvĂ€nds som standard. För backendfunktioner för datakryptering i ngtcp2 stöds quictls, GnuTLS, BoringSSL, Picotls och wolfSSL. Samtidigt med nghttp3 1.0 publicerades Ă€ven den första stabila releasen av ngtcp2 1.0.
KĂ€lla: opennet.ru
