Protokollet HTTP/3.0 har fÄtt status som föreslagen standard

IETF (Internet Engineering Task Force), som arbetar med utvecklingen av internetprotokoll och arkitektur, har slutfört utarbetandet av RFC för protokollet HTTP/3.0 och publicerat relaterade specifikationer med identifierarna RFC 9114 (protokoll) och RFC 9204 (teknologin för komprimering av rubriker QPACK för HTTP/3). Specifikationen för HTTP/3.0 har fÄtt status "Föreslagen standard", efter vilken arbetet med att ge RFC status som utkaststandard (Draft Standard) kommer att inledas, vilket i praktiken betyder full stabilisering av protokollet och beaktande av alla framförda kommentarer. Samtidigt publicerades uppdaterade versioner av specifikationerna för protokollen HTTP/1.1 (RFC 9112) och HTTP/2.0 (RFC 9113), samt dokument som definierar semantik för HTTP-förfrÄgningar (RFC 9110) och HTTP-rubriker för cachekontroll (RFC 9111).

Protokollet HTTP/3 definierar anvÀndningen av protokollet QUIC (Quick UDP Internet Connections) som transport för HTTP/2. QUIC Àr en överbyggnad pÄ UDP-protokollet som stöder multiplexering av flera anslutningar och tillhandahÄller krypteringsmetoder som motsvarar TLS/SSL. Protokollet skapades Är 2013 av Google som ett alternativ till kombinationen TCP+TLS för webben, vilket löser problem med lÄng tid för att etablera och samordna anslutningar i TCP och minskar latens vid paketförlust under datatransmission.

Protokollet HTTP/3.0 har fÄtt status som föreslagen standard

För nÀrvarande har stöd för QUIC och HTTP/3.0 redan implementerats i alla populÀra webblÀsare (i Chrome, Firefox och Edge Àr stöd för HTTP/3 aktiverat som standard, medan det i Safari krÀver aktivering av instÀllningen "Advanced > Experimental Features > HTTP/3"). PÄ serversidan finns implementeringar av HTTP/3 tillgÀngliga för nginx (i en separat gren och som en separat modul), Caddy, IIS och LiteSpeed. Stöd för HTTP/3 erbjuds ocksÄ av innehÄllsleveransnÀtverket Cloudflare.

Huvudfunktioner i QUIC:

  • Hög sĂ€kerhet, liknande TLS (i praktiken ger QUIC möjlighet till anvĂ€ndning av TLS över UDP);
  • Kontroll av strömmens integritet, vilket förhindrar pak förlust;
  • Möjlighet att omedelbart etablera anslutning (0-RTT, i cirka 75% av fallen kan data överföras omedelbart efter att installationspaketet har skickats) och sĂ€kerstĂ€lla minimi-latens mellan begĂ€ran och svar (RTT, Round Trip Time);
    Protokollet HTTP/3.0 har fÄtt status som föreslagen standard
  • AnvĂ€ndning av ett annat sekvensnummer vid omöverföring av paket, vilket undviker tvetydighet vid identifiering av mottagna paket och eliminerar tidsavbrott;
  • Paketsförlust pĂ„verkar endast leveransen av den relaterade strömmen och stoppar inte dataöverföringen i parallella strömmar som sĂ€nds via den aktuella anslutningen;
  • Felkorrekteringsmedel som minimerar förseningar pĂ„ grund av Ă„teröverföring av förlorade paket. AnvĂ€ndning av speciella felkorrekteringskoder pĂ„ paketnivĂ„ för att minska situationer dĂ€r Ă„teröverföring av förlorad data krĂ€vs.
  • GrĂ€nserna för kryptografiska block överensstĂ€mmer med grĂ€nserna för QUIC-paketen, vilket minskar pĂ„verkan av paketförluster pĂ„ avkodningen av innehĂ„llet i efterföljande paket;
  • Ingen köblockering som uppstĂ„r i TCP;
  • Stöd för anslutningsidentifierare som gör att tiden för att Ă„teransluta till mobila kunder minskar;
  • Möjlighet att ansluta avancerade mekanismer för överbelastningskontroll;
  • AnvĂ€ndning av tekniker för kapacitetsprognoser i varje riktning för att sĂ€kerstĂ€lla optimal paketöverföringstakt och förhindra att man hamnar i en överbelastad status dĂ€r paketförluster observeras;
  • En mĂ€rkbar ökning av prestanda och bandbredd jĂ€mfört med TCP. För videotjĂ€nster som YouTube har anvĂ€ndningen av QUIC visat en minskning av buffring under videovisning med 30%.

Bland förÀndringarna i specifikationen för HTTP/1.1 kan nÀmnas förbudet mot anvÀndning av ÄtergÄngssymbolen (CR) utanför innehÄllskroppen, det vill sÀga i protokollens element kan CR endast anvÀndas tillsammans med radmatningssymbolen (CRLF). Algoritmen för chunked-förfrÄgningar har reviderats för att förenkla separationen av bifogade fÀlt och rubriksektionen. Riktlinjer har lagts till för att hantera tvetydigt innehÄll för att blockera attacker av typen 'HTTP Request Smuggling', vilket möjliggör inbrytning i andra anvÀndares förfrÄgningar i flödet mellan frontend och backend.

I uppdateringen av specifikationen för HTTP/2.0 definieras stöd för TLS 1.3 tydligt. Schemat för prioritering och relaterade fÀlt i rubrikerna har klassificerats som förÄldrat. Den underutvecklade mekanismen för uppdatering av anslutning frÄn HTTP/1.1 har förklarats som förÄldrad. Kraven pÄ fÀlt- och vÀrdeförteckningar har minskats. Vissa tidigare reserverade ramtyper och parametrar har föreslagits för anvÀndning. Förbjudna rubrikfÀlt relaterade till anslutningen har definierats mer noggrant.

KĂ€lla: opennet.ru

Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar đŸ”„ Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar | ProHoster