Protokollet QUIC har fÄtt status som föreslaget standard

IETF-kommittén (Internet Engineering Task Force), som arbetar med utveckling av protokoll och arkitektur för internet, har slutfört skapandet av RFC för QUIC-protokollet och publicerat relaterade specifikationer med identifierarna RFC 8999 (versionsoberoende egenskaper hos protokollet), RFC 9000 (transport över UDP), RFC 9001 (TLS-kryptering av QUIC-kommunikationskanalen) och RFC 9002 (överbelastningshantering och bestÀmning av paketförlust vid datatransmission).

RFC har fÄtt status som "Föreslagen standard", varefter arbetet med att ge RFC status som utkaststandard (Draft Standard) kommer att pÄbörjas, vilket i praktiken innebÀr en fullstÀndig stabilisering av protokollet och beaktande av alla framlagda synpunkter. HTTP/3-protokollet, som definierar anvÀndning av QUIC-protokollet som transport för HTTP/2, Àr fortfarande i utkastsspecifikationens stadium, men det kommer snart Àven att standardiseras i IETF.

Det förvÀntas att standardiseringen av QUIC kommer att ge en skjuts för en bredare implementering av detta protokoll samt för utvecklingen av extensioner baserade pÄ det, sÄsom WebTransport (teknik för att skicka och ta emot data mellan webblÀsaren och servern) och MASQUE (teknik för att proxyanslutningar som utökar möjligheterna för SOCKS och HTTP CONNECT och anvÀnder HTTPS över QUIC som transport).

Vi pÄminner om att QUIC-protokollet (Quick UDP Internet Connections) har utvecklats av Google sedan 2013 som ett alternativ till TCP+TLS-kopplingen för webben, som löser problem med lÄng installation och förhandling av anslutningar i TCP och eliminerar fördröjningar vid paketförlust under datatransmission. QUIC Àr ett överliggande protokoll över UDP som stöder multiplexering av flera anslutningar och erbjuder krypteringsmetoder som Àr ekvivalenta med TLS/SSL. Under utvecklingen av standarden i IETF har Àndringar gjorts i protokollet vilket har lett till att tvÄ parallella grenar har uppstÄtt, en för HTTP/3 och den andra som stöds av Google (Chrome stöder bÄda alternativ, medan Firefox stöder IETF-alternativet).

Huvudfunktioner i QUIC:

  • Hög sĂ€kerhet, liknande TLS (i praktiken ger QUIC möjlighet till anvĂ€ndning av TLS över UDP);
  • Kontroll av strömmens integritet, vilket förhindrar pak förlust;
  • Möjlighet att omedelbart etablera anslutning (0-RTT, i cirka 75% av fallen kan data överföras omedelbart efter att installationspaketet har skickats) och sĂ€kerstĂ€lla minimi-latens mellan begĂ€ran och svar (RTT, Round Trip Time);
  • AnvĂ€ndning av ett annat sekvensnummer vid omöverföring av paket, vilket undviker tvetydighet vid identifiering av mottagna paket och eliminerar tidsavbrott;
  • Paketsförlust pĂ„verkar endast leveransen av den relaterade strömmen och stoppar inte dataöverföringen i parallella strömmar som sĂ€nds via den aktuella anslutningen;
  • Felkorrekteringsmedel som minimerar förseningar pĂ„ grund av Ă„teröverföring av förlorade paket. AnvĂ€ndning av speciella felkorrekteringskoder pĂ„ paketnivĂ„ för att minska situationer dĂ€r Ă„teröverföring av förlorad data krĂ€vs.
  • GrĂ€nserna för kryptografiska block överensstĂ€mmer med grĂ€nserna för QUIC-paketen, vilket minskar pĂ„verkan av paketförluster pĂ„ avkodningen av innehĂ„llet i efterföljande paket;
  • Ingen köblockering som uppstĂ„r i TCP;
  • Stöd för anslutningsidentifierare som gör att tiden för att Ă„teransluta till mobila kunder minskar;
  • Möjlighet att ansluta avancerade mekanismer för överbelastningskontroll;
  • AnvĂ€ndning av tekniker för kapacitetsprognoser i varje riktning för att sĂ€kerstĂ€lla optimal paketöverföringstakt och förhindra att man hamnar i en överbelastad status dĂ€r paketförluster observeras;
  • En mĂ€rkbar ökning av prestanda och bandbredd jĂ€mfört med TCP. För videotjĂ€nster som YouTube har anvĂ€ndningen av QUIC visat en minskning av buffring under videovisning med 30%.

KĂ€lla: opennet.ru

Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar đŸ”„ Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar | ProHoster