Implementering av kryptografiska algoritmer GOST i Java

Biblioteket crypto-gost har publicerats med implementering av GOST-kryptoalgoritmer pÄ Java, utan att anvÀnda ytterligare beroenden. Till skillnad frÄn GOST-algoritmerna i biblioteket Castle Bouncy Castle, har crypto-gost högre krypteringsprestanda med algoritmen "Kuznechik", adresserar specifika sÀkerhetsproblem och erbjuder enkla omslag som inte krÀver djup kunskap om kryptografi. Koden levereras under en egen tillstÄndslicens som tillÄter distribution, modifiering och skapande av hÀrledda arbeten utan begrÀnsningar.

Stödda algoritmer:

  • GOST R 34.11-2012 (RFC 6986) — hash-funktionen "Streebog" 256 och 512 bitar.
  • GOST R 34.12-2015 — blockkrypteringen "Kuznechik", nyckel 256 bitar.
  • GOST R 34.13-2015 — krypteringslĂ€gen CBC, CFB, CTR (GAMMA), OFB; autentisering (CMAC).
  • GOST R 34.10-2012 (RFC 7091) — elektronisk signatur 256 och 512 bitar.
  • HMAC-Streebog (RFC 7836, HMAC-Streebog-256 och HMAC-Streebog-512).
  • MGM (Multilinear Galois Mode) — AEAD-lĂ€ge för Kuznechik (RFC 9058). Kompatibel med OpenSSL.
  • SCrypt (RFC 7914) — nyckelgenereringsfunktion baserad pĂ„ lösenord.

KĂ€lla: opennet.ru

Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar đŸ”„ Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar | ProHoster