Efter fem mÄnaders utveckling har OpenSSH 8.5, en öppen implementation av klient och server för att arbeta med protokollen SSH 2.0 och SFTP, lanserats.
Utvecklarna av OpenSSH pÄminde om den kommande övergÄngen till utdaterade algoritmer som anvÀnder SHA-1 hash pÄ grund av ökande effektivitet av kollisionattacker med angivet prefix (kostnaden för att hitta en kollision uppskattas till ungefÀr 50 000 dollar). I en av de kommande versionerna planerar man att som standard inaktivera anvÀndningen av algoritmen för digitala signaturer med öppen nyckel "ssh-rsa", som nÀmns i den ursprungliga RFC:n för protokollet SSH och som fortfarande Àr allmÀnt förekommande i praktiken.
För att kontrollera anvÀndningen av ssh-rsa i sina system kan man försöka ansluta via ssh med alternativet "-oHostKeyAlgorithms=-ssh-rsa". Att inaktivera digitala signaturer "ssh-rsa" som standard innebÀr dock inte ett fullstÀndigt avstÄndstagande frÄn anvÀndningen av RSA-nycklar, eftersom SSH-protokollet tillÄter anvÀndning av andra hash-algoritmer utöver SHA-1. Specifikt kommer anvÀndningen av "rsa-sha2-256" (RSA/SHA256) och "rsa-sha2-512" (RSA/SHA512) att förbli möjlig.
För att underlÀtta övergÄngen till nya algoritmer i OpenSSH 8.5 har instÀllningen UpdateHostKeys aktiverats som standard, vilket automatiskt kan överföra klienterna till mer pÄlitliga algoritmer. Genom denna instÀllning aktiveras en speciell protokollutvidgning "hostkeys@openssh.com", som tillÄter servern att informera klienten om alla tillgÀngliga vÀrdnycklar efter autentisering. Klienten kan spegla dessa nycklar i sin fil ~/ .ssh/known_hosts, vilket möjliggör uppdatering av vÀrdnycklar och förenklar bytet av nycklar. servern.
AnvÀndningen av UpdateHostKeys Àr begrÀnsad av nÄgra villkor som i framtiden kan komma att upphÀvas: nyckeln mÄste nÀmnas i UserKnownHostsFile och fÄr inte anvÀndas i GlobalKnownHostsFile; nyckeln mÄste förekomma under ett enda namn; vÀrdnyckelscertifikat fÄr inte anvÀndas; inga mönster för vÀrdnamn fÄr anvÀndas i known_hosts; instÀllningen VerifyHostKeyDNS mÄste vara inaktiverad; parametro UserKnownHostsFile mÄste vara aktivt.
Bland de rekommenderade algoritmerna för migrering nÀmns rsa-sha2-256/512 baserat pÄ RFC8332 RSA SHA-2 (stöds frÄn OpenSSH 7.2 och anvÀnds som standard), ssh-ed25519 (stöds frÄn OpenSSH 6.5) och ecdsa-sha2-nistp256/384/521 baserat pÄ RFC5656 ECDSA (stöds frÄn OpenSSH 5.7).
Andra förÀndringar:
- Ăndringar relaterade till sĂ€kerhet:
- I ssh-agent har en sÄrbarhet ÄtgÀrdats som orsakats av dubbelfrigöring av redan frigjord minnesomrÄde (double-free). Problemet manifesterar sig frÄn versionen OpenSSH 8.2 och kan potentiellt utnyttjas om en angripare har tillgÄng till ssh-agentens socket pÄ det lokala systemet. Att utnyttja detta försvÄras av att endast root och den ursprungliga anvÀndaren har Ätkomst till socketen. Den mest sannolika angreppsmetoden Àr att omdirigera agenten till ett konto som Àr under angreparens kontroll, eller till en vÀrd dÀr angriparen har root-Ätkomst.
- I sshd har skydd mot överföring av mycket stora parametrar med anvÀndarnamnet till PAM-subsystemet lagts till, vilket gör det möjligt att blockera sÄrbarheter i PAM-systemmoduler (Pluggable Authentication Module). Till exempel möjliggör Àndringen att förhindra att sshd anvÀnds som en vektor för att utnyttja en nyligen upptÀckt root-sÄrbarhet i Solaris (CVE-2020-14871).
- Ăndringar som potentiellt Ă€ventyrar kompatibiliteten:
- I ssh och sshd har den experimentella nyckelutbytesmetoden, motstÄndskraftig mot försök pÄ kvantdatorer, omarbetats. Kvantdatorer löser exponentiellt snabbare problemet att bryta ner ett heltal i primtalsfaktorer, vilket ligger till grund för moderna asymmetriska krypteringsalgoritmer och effektivt Àr olösligt pÄ klassiska processorer. Den anvÀnda metoden baseras pÄ algoritmen NTRU Prime, utvecklad för post-kvanta kryptosystem, och nyckelutbytesmetoden baserad pÄ elliptiska kurvor X25519. IstÀllet för sntrup4591761x25519-sha512@tinyssh.org identifieras metoden nu som sntrup761x25519-sha512@openssh.com (algoritmen sntrup4591761 har ersatts med sntrup761).
- I ssh och sshd har ordningen pÄ annonseringen av stödda algoritmer för digitala signaturer Àndrats. Nu erbjuds ED25519 först istÀllet för ECDSA.
- I ssh och sshd stÀlls parametern TOS/DSCP för kvalitet pÄ tjÀnsten för interaktiva sessioner nu in före TCP-anslutningen.
- I ssh och sshd har stödet för krypteringsmetoden rijndael-cbc@lysator.liu.se, som Àr identisk med aes256-cbc och anvÀndes fram till godkÀnnandet av RFC-4253, avbrutits.
- Som standard Àr parametern CheckHostIP avaktiverad, vilket har en obetydlig nytta, men anvÀndningen komplicerar betydligt nyckelrotationen för vÀrdar bakom belastningsutjÀmnare.
- I sshd har instÀllningarna PerSourceMaxStartups och PerSourceNetBlockSize lagts till för att begrÀnsa intensiteten i start av hanterare i förhÄllande till klientens adress. Dessa parametrar möjliggör en mer finjusterad hantering av begrÀnsningen för processstarter jÀmfört med den allmÀnna instÀllningen MaxStartups.
- I ssh och sshd har en ny instÀllning LogVerbose lagts till, vilket gör det möjligt att tvinga upp nivÄn av debuginformation som loggas, med möjlighet till filtrering efter mönster, funktioner och filer.
- I ssh, nÀr en ny vÀrdnyckel accepteras, visas alla vÀrdnamn och IP-adresser, associerade med nyckeln.
- I ssh Àr det nu tillÄtet att ange alternativet UserKnownHostsFile=none för att inaktivera anvÀndningen av known_hosts-filen vid identifiering av vÀrdnycklar.
- I ssh_config har instÀllningen KnownHostsCommand lagts till för ssh, vilket möjliggör att hÀmta data om known_hosts frÄn utdata av ett angivet kommando.
- I ssh_config har alternativet PermitRemoteOpen lagts till för ssh, vilket begrÀnsar destinationspunkten nÀr alternativet RemoteForward anvÀnds med SOCKS.
- I ssh krÀvs det en ny PIN-kod vid misslyckad operation med digital signatur pÄ grund av felaktig PIN-kod och avsaknad av en PIN-förfrÄgan frÄn anvÀndaren (till exempel nÀr korrekta biometriska data inte kunde inhÀmtas och enheten Ätergick till manuell PIN-inmatning).
- I sshd har stöd för ytterligare systemanrop lagts till i den processisolationsmekanism baserad pÄ seccomp-bpf pÄ Linux-plattformen.
- Verktyget contrib/ssh-copy-id har uppdaterats.
KĂ€lla: opennet.ru
