Flera nyligen identifierade sÄrbarheter:
- CVE-2023-39191 â en sĂ„rbarhet i eBPF-subsystemet som möjliggör för en lokal anvĂ€ndare att höja sina privilegier och köra kod pĂ„ Linux-kĂ€rnnivĂ„. SĂ„rbarheten orsakas av bristande kontroll av eBPF-program som anvĂ€ndare skickar för körning. För att utföra en attack mĂ„ste anvĂ€ndaren ha möjlighet att ladda upp sitt BPF-program (om parametern kernel.unprivileged_bpf_disabled Ă€r instĂ€lld pĂ„ 0, exempelvis som i Ubuntu 20.04). Information om sĂ„rbarheten har skickats till kĂ€rnans utvecklare redan i december förra Ă„ret, och en fix har diskret lagts till i januari.
- CVE-2023-42753 â ett fel i hanteringen av arrayindex i ipset-implementationen inom netfilter-kĂ€rnsystemet, vilket kan utnyttjas för att inkrementera/dekrementera pekare och skapa förhĂ„llanden för att skriva eller lĂ€sa utanför det allokerade minnet. En prototyp av ett exploit för att kontrollera sĂ„rbarheten har förberetts, vilket ger en krasch (mer avancerade utnyttjande-scenarier Ă€r inte uteslutna). Fixa har inkluderats i versionerna av kĂ€rnan 5.4.257, 6.5.3, 6.4.16, 6.1.53, 5.10.195, 5.15.132.
- CVE-2023-39192, CVE-2023-39193, CVE-2023-39194 â flera sĂ„rbarheter i Linux-kĂ€rnan som leder till lĂ€ckage av kernelminne pĂ„ grund av möjligheten att lĂ€sa frĂ„n omrĂ„den utanför det allokerade buffret i funktionerna match_flags och u32_match_it i Netfilter-subsystemet, samt i koden för tillstĂ„ndsfiltret. SĂ„rbarheterna Ă„tgĂ€rdades i augusti (1, 2) och juni.
- CVE-2023-42755 â en sĂ„rbarhet som tillĂ„ter en icke-privilegierad lokal anvĂ€ndare att orsaka en kĂ€rnkrasch pĂ„ grund av ett fel i pekarhanteringen i RSVP-trafikklassificeraren. Problemet förekommer i LTS-kĂ€rnor 6.1, 5.15, 5.10, 5.4, 4.19 och 4.14. En prototyp av exploit har förberedts. Fixa har Ă€nnu inte accepterats i kĂ€rnan och Ă€r tillgĂ€nglig som en patch.
- CVE-2023-42756 â ett race condition i NetFilter-kĂ€rnsystemet som kan anvĂ€ndas av en lokal anvĂ€ndare för att fĂ„ tillstĂ„ndet Panic. En prototyp av exploit som fungerar i alla fall i kĂ€rnor 6.5.rc7, 6.1 och 5.10 Ă€r tillgĂ€nglig. Fixa har Ă€nnu inte accepterats i kĂ€rnan och finns tillgĂ€nglig som en patch.
- CVE-2023-4527 â stack overflow in the Glibc library, occurring in the getaddrinfo function when processing a DNS response larger than 2048 bytes. The vulnerability may lead to data leakage from the stack or a crash. The vulnerability is present only in Glibc versions newer than 2.36 when using the 'no-aaaa' option in /etc/resolv.conf.
- CVE-2023-40474, CVE-2023-40475 â vulnerabilities in the GStreamer multimedia framework, caused by an integer overflow in handlers for MXF video files. These vulnerabilities may lead to the execution of attacker code when processing specially crafted MXF files in an application using GStreamer. The issue is fixed in package gst-plugins-bad 1.22.6.
- CVE-2023-40476 â buffer overflow in the GStreamer video handler for H.265, allowing code execution when processing specially crafted video. The vulnerability is fixed in package gst-plugins-bad 1.22.6.
- Analysis â analysis of the exploit using the CVE-2023-36664 vulnerability in the Ghostscript package to execute custom code when opening specially crafted PostScript documents. The issue is caused by incorrect handling of file names starting with the character â|â or the %pipe% prefix. The vulnerability is fixed in the Ghostscript 10.01.2 release.
- CVE-2023-3341, CVE-2023-4236 â vulnerabilities in the BIND 9 DNS server, leading to a crash of the named process when processing specially crafted control messages (access to the TCP port through which named is controlled is sufficient, it is only open for the loopback interface by default, knowledge of the RNDC key is not required) or causing a certain high load in DNS-over-TLS mode. The vulnerabilities are fixed in BIND 9.16.44, 9.18.19, and 9.19.17 releases.
- CVE-2023-4504 â a vulnerability in servern CUPS printing and the libppd library, leading to a buffer overflow when processing specially crafted PostScript documents. Exploitation of the vulnerability to execute custom code in the system cannot be ruled out. The issue is fixed in CUPS releases 2.4.7 (patch) and libppd 2.0.0 (patch).
KĂ€lla: opennet.ru
