FreeBSD 12.3 har slÀppts, som publicerats för arkitekturerna amd64, i386, powerpc, powerpc64, powerpcspe, sparc64 samt armv6, armv7 och aarch64. Dessutom har bilder för virtualiseringssystem (QCOW2, VHD, VMDK, raw) och Amazon EC2-molnmiljöer förberetts. FreeBSD 13.1 förvÀntas i vÄr 2022.
Nyckelinnovationer:
- En skript har lagts till i /etc/rc.final, som körs i den sista fasen efter att alla anvÀndarprocesser har avslutats.
- Paketfilter ipfw har en dnctl-kommandon för att hantera instÀllningar för dummynet trafikbegrÀnsning.
- Sysctl kern.crypto har lagts till för att hantera kÀrnans kryptosubsystem samt en debug sysctl debug.uma_reclaim.
- Sysctl net.inet.tcp.tolerate_missing_ts har lagts till, vilket tillÄter TCP-paket utan tidsstÀmplar (timestamp, RFC 1323/RFC 7323).
- I GENERIC-kÀrnan för amd64-arkitekturen har alternativet COMPAT_LINUXKPI lagts till och drivern mlx5en (NVIDIA Mellanox ConnectX-4/5/6) aktiverats.
- I bootloadern har möjligheten att ladda operativsystemet frÄn ramdisk lagts till, och stöd för ZFS-alternativen com.delphix:bookmark_written samt com.datto:bookmark_v2 har implementerats.
- Biblioteket fetch har lagt till stöd för FTP-proxifiering över HTTPS.
- Paketförvaltaren pkg har implementerat flaggorna «-r» för kommandona «bootstrap» och «add» för att ange repository. AnvÀndning av miljövariabler frÄn filen pkg.conf sÀkerstÀlls.
- I verktyget growfs har det lagts till möjligheter att arbeta med filsystem som Àr monterade i lÀs- och skrivlÀge.
- I verktyget etcupdate har ÄterstÀllningslÀget för att ÄterstÀlla en eller flera filer implementerats. Flaggan «-D» har lagts till för att ange mÄl katalog. Data kan utlÀsas med anvÀndning av en temporÀr katalog, och SIGINT har integrerats.
- I verktygen freebsd-update och freebsd-version har flaggan «-j» lagts till för stöd av jail-miljöer.
- Verktyget cpuset kan nu anvÀndas i jail-miljöer för att Àndra parametrar för underordnade jail.
- I verktyget cmp har alternativ lagts till: «-b» (âprint-bytes) för att visa de olika bytena, «-i» (âignore-initial) för att ignorera ett visst antal inledande byte, «-n» (âbytes) för att begrĂ€nsa antalet jĂ€mförda byte.
- I verktyget daemon har flaggan «-H» lagts till för att behandla SIGHUP och Äteröppna filerna dÀr utdata sker (tillÀgg för att stödja newsyslog).
- I verktyget fstyp har flaggan «-l» lagts till för att bestÀmma och visa exFAT-filsystem.
- I verktyget mergemaster implementerades hantering av symboliska lÀnkar under uppdateringsprocessen.
- I verktyget newsyslog har en flagga "E" lagts till för att inaktivera rotation av tomma loggar.
- I verktyget tcpdump har möjligheten att avkoda paket pÄ pfsync-grÀnssnitt lagts till.
- I verktyget top har kommandot-filtret "/" lagts till för att visa endast processer eller argument som matchar den angivna strÀngen.
- I unzip har stöd för lösenordsskyddade arkiv lagts till.
- Stödet för hÄrdvara har förbÀttrats. PCI-enhetsidentifierare har lagts till för AHCI-kontroller frÄn ASMedia ASM116x och I2C-kontroller frÄn Intel Gemini Lake. Stöd har implementerats för nÀtverkskort frÄn Mikrotik 10/25G och trÄdlösa kort frÄn Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. En ny drivrutin igc för ethernetkontroller frÄn Intel I225 2.5G/1G/100MB/10MB har lagts till.
- Netgraph-noden ng_bridge har anpassats för SMP-system. I noden ng_nat har stöd för CGN (Carrier Grade NAT, RFC 6598) lagts till. Möjlighet att ersÀtta noden ng_source i vilken del som helst av Netgraph-nÀtverket har tillhandahÄllits.
- I drivrutinen rctl, som anvÀnds för att begrÀnsa resurser, har möjligheten att stÀlla in resursanvÀndningsgrÀnsen till ett vÀrde av 0 lagts till.
- I grÀnssnittet vlan har stöd för trafikhanteringsprioritering och kapacitetskontroll ALTQ lagts till.
- I drivrutinerna amdtemp och amdsmn har stöd för CPU Zen 3 "Vermeer" och APU Ryzen 4000 (Zen 2, "Renoir") implementerats.
- Versionerna av tredjepartsapplikationer som ingÄr i basystemet har uppdaterats: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Verktyget unzip har synkroniserats med kodbasen för NetBSD.
KĂ€lla: opennet.ru
