Lanseringen av den lÀtta http-servern lighttpd 1.4.65 har Àgt rum, och den strÀvar efter att kombinera hög prestanda, sÀkerhet, standardöverensstÀmmelse och konfigurationsflexibilitet. Lighttpd Àr lÀmplig för anvÀndning i högbelastade system och fokuserar pÄ lÄgt minnes- och CPU-anvÀndande. Den nya versionen innehÄller 173 Àndringar. Projektets kod Àr skriven i C och distribueras under BSD-licensen.
Huvudsakliga nyheter:
- Stöd har lagts till för WebSocket över HTTP/2, samt har RFC 8441 implementerats, vilket beskriver mekanismen för att starta WebSocket-protokollet i en ström inom HTTP/2-anslutningen.
- En utökad prioriteringshanteringsschema har implementerats, vilket ger klienten möjligheten att pÄverka prioriteten för överförda servern svar (RFC 9218) samt för att hantera prioriteringar vid omdirigering av förfrÄgningar. För HTTP/2 har stöd för PRIORITY_UPDATE-ramverket införts.
- I instÀllningarna för lighttpd.conf har stöd för villkorliga matchningar med början (=^) och slutet (=$) av strÀngen lagts till. SÄdana strÀngkontroller Àr betydligt snabbare Àn reguljÀra uttryck och tillrÀckliga för mÄnga enkla kontroller.
- I mod_webdav har stöd för delvisa PUT-operationer (som omfattar en del av data med hjÀlp av headern Range) lagts till. För att aktivera kan alternativet 'webdav.opts += ("partial-put-copy-modify" => "enable")' anvÀndas.
- I mod_accesslog har alternativet 'accesslog.escaping = "json"' lagts till.
- I mod_deflate har stöd för byggnation med libdeflate lagts till.
- Ăverföringen av förfrĂ„gningskroppen över HTTP/2 har pĂ„skyndats.
- VÀrdet för parametern server.max-keep-alive-requests har som standard Àndrats frÄn 100 till 1000.
- I listan över MIME-typer har "application/javascript" ersatts av "text/javascript" (RFC 9239).
Framtida planer omfattar anvÀndning av striktare instÀllningar för krypteringar för TLS och att inaktivera förÄldrade krypteringar som standard. InstÀllningen CipherString kommer att Àndras frÄn "HIGH" till "EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384". Dessutom planeras borttagning av förÄldrade TLS-alternativ: ssl.honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3. Dessutom kommer stÀdningen av mini-moduler att fortsÀtta, som kan ersÀttas med en mer flexibel Lua-implementation av mod_magnet. Specifikt planeras borttagning av modulerna mod_evasive, mod_secdownload, mod_uploadprogress och mod_usertrack.
KĂ€lla: opennet.ru
