Efter fem mÄnaders utveckling har versionen av OpenSSL 3.3.0 slÀppts med implementering av SSL/TLS-protokoll och olika krypteringsalgoritmer. Stödet för OpenSSL 3.3 kommer att pÄgÄ till april 2026. Stödet för Àldre versioner av OpenSSL 3.2, 3.1 och 3.0 LTS kommer att fortsÀtta till november 2025, mars 2025 och september 2026 respektive. Projektets kod distribueras under Apache 2.0-licensen.
Huvudnyheterna i OpenSSL 3.3.0:
- Stödet för QUIC-protokollet (RFC 9000) har fortsatt att integreras, vilket Àr en överbyggnad över UDP-protokollet, som anvÀnds som transport i HTTP/3-protokollet. I den nya versionen:
- Stöd för spÄrning av QUIC-anslutningar genom att föra en diagnostisk logg i qlog-format har lagts till.
- Stöd för polling i icke-blockerande lÀge för QUIC-anslutningar och strömobjekt har lagts till.
- Möjligheten för optimerad generering av slutstream-ramar för QUIC-anslutningar har realiserats.
- Det har tillhandahÄllits möjlighet att stÀnga av bearbetning av QUIC-hÀndelser vid API-anrop.
- Stöd för att stÀlla in tidsgrÀns för inaktivitet för QUIC har lagts till.
- Ett API för att begÀra storlek och fyllningsgrad av skrivbufferten för QUIC-strömmar har lagts till.
- FörbÀttringar av protokollet för certifikathantering CMP (Certificate Management Protocol) har implementerats, definierade i specifikationerna RFC 9480 (definition av CMPv3) och RFC 9483 (lÀttviktsprofil för lÄgströmsenheter).
- Möjligheten att stÀnga av anvÀndningen av atexit-funktionen under byggsteget har lagts till.
- En ny variant av SSL_SESSION API, som inte Àr pÄverkad av 2038-problemet, har lagts till: funktionerna SSL_SESSION_get_time_ex() och SSL_SESSION_set_time_ex() anvÀnder 64-bitars time_t pÄ 32-bitars system.
- I funktionen EVP_PKEY_fromdata har möjligheten att automatiskt hÀmta parametrar frÄn kinesiska resten teoremet (CRT, Chinese Remainder Theorem) implementerats.
- Möjligheten att ignorera okÀnda namn pÄ signeringsalgoritmer, angivna i TLS SignatureAlgorithms och ClientSignatureAlgorithms konfigurationsparametrar, har lagts till.
- Möjligheten att stÀlla in prioriterad anvÀndning av PSK-nycklar pÄ servern TLS 1.3 under ÄterstÀllande av sessioner har lagts till.
- Funktionen EVP_DigestSqueeze(), som möjliggör att reducera storleken pÄ SHAKE-hashen (genom att ta bort högre bitar) med hjÀlp av flera iterationer med olika utmatningsstorlekar, har lagts till.
- Stöd för export av byggfiler för CMake pÄ Unix-liknande system och Windows (utöver export baserad pÄ pkg-config) har lagts till.
- Prestandaoptimeringar har genomförts: Prestandan hos AES-GCM-algoritmen har optimerats för enheter med Microsoft Azure Cobalt 100-chip. AES-CTR-implementeringen har fÄtt stöd för acceleration med ARM Neoverse V1 och V2. Optimeringar av AES och SHA3 har inkluderats för Apple-system med M3-chip. Vektoriserade utvidgningar av RISC-V anvÀnds i olika kryptografiska funktioner. En assemblerimplementering av md5 har lagts till för CPU Loongarch64.
KĂ€lla: opennet.ru
