UtslÀppet av kryptografiska biblioteket OpenSSL 4.0.0

OpenSSL 4.0.0 har nu slÀppts och erbjuder implementation av TLS-protokoll och olika krypteringsalgoritmer. OpenSSL 4.0 kategoriseras som en version med normalt stöd, dÀr uppdateringar slÀpps under 13 mÄnader. Stödet för tidigare versioner, OpenSSL 3.6, 3.5 LTS, 3.4 och 3.0 LTS, kommer att fortsÀtta fram till november 2026, april 2030, oktober 2026 och september 2026 respektive. Projektkoden distribueras under Apache 2.0-licensen.

Huvudsakliga nyheter:

  • Stöd för TLS-tillĂ€gget ECH (Encrypted ClientHello, RFC 9849) har lagts till, vilket syftar till att kryptera information om TLS-sessionens parametrar, sĂ„som det begĂ€rda domĂ€nnamnet. Till skillnad frĂ„n ESNI (Encrypted Server Name Indication) krypterar ECH hela TLS-meddelandet ClientHello istĂ€llet för att kryptera pĂ„ nivĂ„er av enskilda fĂ€lt. Detta förhindrar lĂ€ckor genom fĂ€lt som inte omfattas av ESNI, till exempel PSK-fĂ€ltet (Pre-Shared Key).
  • Stöd för vissa algoritmer definierade i RFC 8998, som anvĂ€nder den i Kina standardiserade uppsĂ€ttningen kryptografiska algoritmer SM2, har lagts till: algoritmen för digital signaturproduktion sm2sig_sm3, gruppen för nyckelutbyte curveSM2 och postkvantgrupp curveSM2MLKEM768.
  • Den kryptografiska hash-funktionen cSHAKE har lagts till, baserad pĂ„ SHA-3-algoritmen, vilket gör det möjligt att skapa olika hashes baserat pĂ„ samma indata för att skydda mot attacker som manipulerar med Ă„teranvĂ€ndning av data.
  • Den hybridalgoritm "ML-DSA-MU" har lagts till, som kombinerar postkvant-algoritmen för digital signatur ML-DSA (CRYSTALS-Dilithium) med den klassiska hash-funktionen SHAKE256.
  • Stöd för SNMP KDF-nyckelgenereringsfunktioner baserade pĂ„ HMAC-SHA och SRTP KDF baserade pĂ„ AES-CM har lagts till, som anvĂ€nds i nĂ€tverksprotokollen SNMPv3 och SRTP för att skapa kryptografiska nycklar.
  • Kommandot "openssl fipsinstall" har fĂ„tt alternativet "-defer_tests", vilket tillĂ„ter att tester skjuts upp vid installation av FIPS-moduler.
  • Stöd för anvĂ€ndning av statisk eller dynamisk lĂ€nkning med Visual C++ Runtime har implementerats för Windows-plattformen.
  • Stöd för nyckelutbytesförhandling baserad pĂ„ FFDHE-algoritmen, enligt RFC 7919, har lagts till i TLS 1.2.
  • Stödet för SSLv3 och SSLv2 Client Hello har upphört.
  • Stödet för dynamiskt laddade motorer har tagits bort; istĂ€llet ska konceptet av plug-in-leverantörer anvĂ€ndas för att utöka OpenSSL:s funktionalitet.
  • I TLS inaktiverades stöd för förĂ„ldrade elliptiska kurvor vid kompilering. För att Ă„teraktivera kan alternativet «enable-tls-deprecated-ec» anvĂ€ndas.
  • Verktyget c_rehash har tagits bort, istĂ€llet bör kommandot «openssl rehash» anvĂ€ndas.
  • Den förĂ„ldrade optionen «msie-hack» har tagits bort frĂ„n kommandot «openssl ca».
  • Stödet för de egna metoderna EVP_CIPHER, EVP_MD, EVP_PKEY och EVP_PKEY_ASN1 har tagits bort.
  • FörĂ„ldrade SSL/TLS-funktioner kopplade till fasta versioner av protokollen, sĂ„som «TLSv1_client_method()», har tagits bort.
  • Funktionerna ERR_get_state(), ERR_remove_state() och ERR_remove_thread_state() har tagits bort.
  • Stödet för mĂ„lenheterna darwin-i386{,-cc} och darwin-ppc{,64}{,-cc} har avbrutits.

KĂ€lla: opennet.ru

Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar đŸ”„ Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar | ProHoster