Efter Ätta mÄnaders utveckling har release av OpenSSL 3.2.0 med implementering av SSL/TLS-protokoll och olika krypteringsalgoritmer blivit fÀrdig. Stöd för OpenSSL 3.2 kommer att ges fram till den 23 november 2025. Stöd för tidigare versioner OpenSSL 3.1 och 3.0 LTS kommer att fortsÀtta fram till mars 2025 respektive september 2026. Stödet för version 1.1.1 avslutades i september i Är. Projektkoden distribueras under Apache 2.0-licensen.
Huvudnyheterna i OpenSSL 3.2.0:
- Klientstöd för QUIC-protokollet (RFC 9000) har lagts till, vilket anvÀnds som transport i HTTP/3-protokollet. Implementeringen inkluderar bland annat möjligheten att överföra flera strömmar över en enda kommunikationskanal. Komponenter för att anvÀnda QUIC pÄ servrar kommer att ingÄ i OpenSSL 3.3-release, som planeras att publiceras senast den 30 april 2024.
QUIC Àr en överbyggnad pÄ UDP-protokollet som stöder multiplexering av flera anslutningar och erbjuder krypteringsmetoder som Àr likvÀrdiga med TLS/SSL. Protokollet skapades 2013 av Google som ett alternativ till kombinationen TCP+TLS för webben, vilket löser problemen med lÄng tid för etablering och överenskommelse av anslutningar i TCP och eliminerar fördröjningar vid paketförlust under dataöverföring.
- TLS har implementerat stöd för en förlÀngning för kompression av certifikat under anslutningsförhandlingen (RFC 8879), vilket möjliggör en snabbare anslutningsprocess dÄ överföringen av certifikatsdata utgör en stor del av trafiken under anslutningsförhandlingen. Kompression stöds med hjÀlp av biblioteken zlib, zstd och Brotli.
- Stöd för det deterministiska alternativet för digitala signaturer ECDSA (Deterministic ECDSA, RFC 6979) har lagts till, dÀr en hash HMAC-SHA256 av den privata nyckeln och den signerade meddelandetexten anvÀnds istÀllet för en slumpmÀssig sekvens vid signaturgenerering. Detta gör att man alltid fÄr samma signatur vid olika signeringsoperationer, men utesluter lÀckage av data som kan anvÀndas för att knÀcka den privata nyckeln (den privata nyckeln kan knÀckas om minst tvÄ signaturer för olika data har genererats med en repetitiv slumpmÀssig sekvens).
- Stöd för utökade varianter av digitala signaturer med offentlig nyckel Ed25519 och Ed448 har lagts till: Ed25519ctx, Ed25519ph och Ed448ph (RFC 8032).
- Stöd för AES-GCM-SIV krypteringslÀget (RFC 8452) har lagts till, vilket kombinerar den höga prestandan av GCM-lÀget (Galois/Counter Mode) med motstÄndskraft mot lÀckage vid ÄteranvÀndning av slumpkod nonce.
- Funktionen för att generera Argon2-nycklar (RFC 9106) har implementerats, som vann en tÀvling om hash-algoritmer för lösenord 2015. Möjlighet att anvÀnda trÄdpooler har lagts till.
- Stöd för hybridkryptering baserad pÄ HPKE-mekanismen (Hybrid Public Key Encryption, RFC 9180) har lagts till, som kombinerar enkelheten i nyckelöverföring med hög prestanda för symmetrisk kryptering (data krypteras med en snabb symmetrisk nyckel, medan sjÀlva nyckeln krypteras med en lÄngsam asymmetrisk metod).
- I TLS har möjligheten att anvÀnda 'rÄa' (raw) offentliga nycklar (RFC 7250) implementerats.
- Stöd för TCP Fast Open (TFO, RFC 7413) har lagts till, vilket möjliggör snabbare öppning av TCP-anslutningar genom att kombinera de första tvÄ stegen av den klassiska 3-stegs anslutningsprocessen i en enda begÀran, vilket möjliggör överföring av data i det initiala steget av anslutningsupprÀttandet.
- I TLS har stöd för pluggbara digitala signaturmodeller implementerats, vilket möjliggör anvÀndning av externa implementeringar av algoritmer, som för anvÀndning av kvantmotstÄndskraftiga algoritmer i TLS.
- I TLS 1.3 har stöd för skyddade elliptiska kurvor av typen Brainpool lagts till.
- Stöd för SM4-XTS processorinstruktioner har lagts till.
- PÄ Windows-plattformen har möjlighet att anvÀnda systemets lagring för rotcertifikat implementerats (standard Àr avstÀngd). För att referera till certifikat i Windows-lagringen föreslÄs URI 'org.openssl.winstore://'.
KĂ€lla: opennet.ru
