Kategori: Blogg

JingOS 0.9, en distribution för surfplattor, Àr nu tillgÀnglig.

Den nya versionen av JingOS 0.9 har publicerats, vilket erbjuder en miljö speciellt optimerad för installation pĂ„ surfplattor och bĂ€rbara datorer med pekskĂ€rm. Projektet utvecklas av det kinesiska företaget Jingling Tech, som har ett kontor i Kalifornien. Utvecklingsteamet inkluderar medarbetare som tidigare arbetat pĂ„ företag som Lenovo, Alibaba, Samsung, Canonical/Ubuntu och Trolltech. Storleken pĂ„ installationsavbilden Ă€r 3 GB (x86_64). Projektets arbete distribueras under licensen […]

Release of OpenRGB 0.6, a toolkit for managing RGB-lit devices

Den nya versionen av OpenRGB 0.6 har publicerats, ett gratis verktyg för att styra RGB-belysningsenheter. Paketet stöder moderkort frĂ„n ASUS, Gigabyte, ASRock och MSI med RGB-system för chassibelysning, minnesmoduler med belysning frĂ„n ASUS, Patriot, Corsair och HyperX, grafikkort frĂ„n ASUS Aura/ROG, MSI GeForce, Sapphire Nitro och Gigabyte Aorus, samt olika kontroller för lysdioder (ThermalTake, Corsair, NZXT Hue+), […]

För sprÄk D finns en runtime för programmering av mikrokontroller.

Dylan Graham har presenterat en lĂ€ttvikts runtime LWDR för programmering i sprĂ„ket D för mikrokontroller utrustade med realtidsoperativsystem (RTOS). Den nuvarande versionen riktar sig till ARM Cortex-M mikrokontroller. Utvecklingen syftar inte till att tĂ€cka alla funktioner i D, men ger grundlĂ€ggande verktyg. Minnesallokeringen sker manuellt (new / delete), skrĂ€psamlaren Ă€r inte implementerad, men det finns en rad hooks för […]

UtgÄvan av applikationsservern NGINX Unit 1.24.0

UtgĂ„van av applikationsservern NGINX Unit 1.24 har Ă€gt rum, dĂ€r lösningen utvecklas för att starta web-applikationer pĂ„ olika programmeringssprĂ„k (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js och Java). Under NGINX Unit kan flera applikationer pĂ„ olika programmeringssprĂ„k köras samtidigt, och startparametrarna kan Ă€ndras dynamiskt utan att behöva redigera konfigurationsfiler och starta om. Koden […]

Utgivning av Electron 13.0.0, plattformen för skapande av applikationer baserade pÄ Chromium-motorn

UtgĂ„van av plattformen Electron 13.0.0 Ă€r förberedd, vilket erbjuder en sjĂ€lvgĂ„ende ram för utveckling av plattformsoberoende anvĂ€ndarapplikationer, baserat pĂ„ komponenter frĂ„n Chromium, V8 och Node.js. Den signifikanta versionsĂ€ndringen beror pĂ„ uppdateringen till Chromium 91-kĂ€llkoden, Node.js 14.16-plattformen och JavaScript-motorn V8 9.1. Bland Ă€ndringarna i den nya utgĂ„van: Egenskapen process.contextIsolated har lagts till för att bestĂ€mma utförandet av den aktuella […]

UtgÄvan av PCRE2-biblioteket 10.37

UtgĂ„van av biblioteket PCRE2 10.37 har slĂ€ppts, som erbjuder en uppsĂ€ttning funktioner pĂ„ C för implementering av reguljĂ€ra uttryck och mönstermatchning, nĂ€ra i syntax och semantik till reguljĂ€ra uttryck i Perl 5. PCRE2 Ă€r en omarbetad implementation av det ursprungliga PCRE-biblioteket med ett icke-kompatibelt API och utökade funktioner. Biblioteket Ă€r utvecklat av skaparna av e-postservern Exim och distribueras […]

Microsoft har slÀppt Windows Package Manager 1.0, en paketmanager som liknar apt och dnf.

Microsoft har publicerat utgĂ„van av Windows Package Manager 1.0 (winget), som tillhandahĂ„ller verktyg för att installera applikationer via kommandoraden. Koden Ă€r skriven i C++ och distribueras under MIT-licensen. Paket installeras frĂ„n ett repository som stöds av gemenskapen. Till skillnad frĂ„n installation av program via Microsoft Store tillĂ„ter winget att installera applikationer utan onödig marknadsföring och […]

UtgÄvor av paketförvaltaren Pacman 6.0 och installatören Archinstall 2.2.0

Nya versioner av paketförvaltaren Pacman 6.0.0 och installationsprogrammet Archinstall 2.2.0 har slĂ€ppts, som anvĂ€nds i Arch Linux-distributionen. Huvudsakliga Ă€ndringar i Pacman 6.0: Stöd för nedladdning av filer i flera parallella strömmar har lagts till. En rad för att indikera nedladdningsprogression har implementerats. För att stĂ€nga av progressindikatorn kan alternativet «—noprogressbar» anges i pacman.conf. Automatisk överspringande av speglar har sĂ€kerstĂ€llts nĂ€r man kontaktar dem […]

Koden för tjÀnsten för att kontrollera lösenord HaveIBeenPwned har öppnats

Troy Hunt har öppnat kĂ€llkoden för tjĂ€nsten "Have I Been Pwned?" (haveibeenpwned.com), som kontrollerar mot en databas med 11,2 miljarder anvĂ€ndarkonton som har stulits vid hackningar av 538 webbplatser. Initialt tillkĂ€nnagavs avsikten att öppna projektets kod i augusti förra Ă„ret, men processen har dragit ut pĂ„ tiden och koden publicerades först nu. TjĂ€nstens kod Ă€r skriven i […]

Mozilla sammanfattade planerna för att stödja tredje versionen av Chrome-manifestet i Firefox

Mozilla har publicerat planen för implementeringen av i Firefox den tredje versionen av Chrome-manifestet, som definierar de möjligheter och resurser som tillhandahĂ„lls för tillĂ€gg. Den tredje versionen av manifestet har blivit föremĂ„l för kritik pĂ„ grund av att det pĂ„verkar mĂ„nga tillĂ€gg för blockering av oönskat innehĂ„ll och sĂ€kerhet. I Firefox avser man att implementera nĂ€stan alla möjligheter och begrĂ€nsningar i det nya manifestet, inklusive deklarativt API för filtrering av innehĂ„ll (declarativeNetRequest), […]

Protokollet QUIC har fÄtt status som föreslaget standard

IETF (Internet Engineering Task Force), som ansvarar för utvecklingen av protokoll och arkitektur för internet, har slutfört utarbetandet av RFC för protokollet QUIC och publicerat relaterade specifikationer med identifierarna RFC 8999 (versionsoberoende protokollegenskaper), RFC 9000 (transport över UDP), RFC 9001 (TLS-kryptering av QUIC-kommunikationskanalen) och RFC 9002 (belastningshantering och packetförlustbestĂ€mning vid datatransmission). […]

Virtuozzo har publicerat distributionen VzLinux, riktad mot att ersÀtta CentOS 8

Virtuozzo, som tidigare var en del av Parallels, har börjat sprida distributionsen VzLinux offentligt. Detta system anvĂ€ndes tidigare som basoperativsystem för sin egen virtualiseringsplattform samt för olika kommersiella produkter. Nu finns VzLinux tillgĂ€ngligt för alla och marknadsförs som en ersĂ€ttning för CentOS 8, redo för företagsanvĂ€ndning. För nedladdning […]

Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar đŸ”„ Köp pĂ„litlig webbhotell med DDoS-skydd, VPS VDS-servrar | ProHoster