{"id":111732,"date":"2023-11-24T15:10:17","date_gmt":"2023-11-24T13:10:17","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic"},"modified":"2023-11-24T15:10:17","modified_gmt":"2023-11-24T13:10:17","slug":"vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","status":"publish","type":"post","link":"https:\/\/prohoster.info\/sv\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","title":{"rendered":"Utg\u00e5van OpenSSL 3.2.0 med klientst\u00f6d f\u00f6r protokollet QUIC","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Efter \u00e5tta m\u00e5naders utveckling har release av OpenSSL 3.2.0 med implementering av SSL\/TLS-protokoll och olika krypteringsalgoritmer blivit f\u00e4rdig. St\u00f6d f\u00f6r OpenSSL 3.2 kommer att ges fram till den 23 november 2025. St\u00f6d f\u00f6r tidigare versioner OpenSSL 3.1 och 3.0 LTS kommer att forts\u00e4tta fram till mars 2025 respektive september 2026. St\u00f6det f\u00f6r version 1.1.1 avslutades i september i \u00e5r. Projektkoden distribueras under Apache 2.0-licensen.    <\/p>\n<p>Huvudnyheterna i OpenSSL 3.2.0:   <\/p>\n<ul>\n<li class=\"l\"> Klientst\u00f6d f\u00f6r QUIC-protokollet (RFC 9000) har lagts till, vilket anv\u00e4nds som transport i HTTP\/3-protokollet. Implementeringen inkluderar bland annat m\u00f6jligheten att \u00f6verf\u00f6ra flera str\u00f6mmar \u00f6ver en enda kommunikationskanal. Komponenter f\u00f6r att anv\u00e4nda QUIC p\u00e5 <a class=\"wpil_keyword_link\" href=\"https:\/\/prohoster.info\/sv\/server\/dts-gdansk\/\"   title=\"servrar\" data-wpil-keyword-link=\"linked\"  data-wpil-monitor-id=\"4541\">servrar<\/a> kommer att ing\u00e5 i OpenSSL 3.3-release, som planeras att publiceras senast den 30 april 2024.\n<p>QUIC \u00e4r en \u00f6verbyggnad p\u00e5 UDP-protokollet som st\u00f6der multiplexering av flera anslutningar och erbjuder krypteringsmetoder som \u00e4r likv\u00e4rdiga med TLS\/SSL. Protokollet skapades 2013 av Google som ett alternativ till kombinationen TCP+TLS f\u00f6r webben, vilket l\u00f6ser problemen med l\u00e5ng tid f\u00f6r etablering och \u00f6verenskommelse av anslutningar i TCP och eliminerar f\u00f6rdr\u00f6jningar vid paketf\u00f6rlust under data\u00f6verf\u00f6ring.       <\/p>\n<li class=\"l\"> TLS har implementerat st\u00f6d f\u00f6r en f\u00f6rl\u00e4ngning f\u00f6r kompression av certifikat under anslutningsf\u00f6rhandlingen (RFC 8879), vilket m\u00f6jligg\u00f6r en snabbare anslutningsprocess d\u00e5 \u00f6verf\u00f6ringen av certifikatsdata utg\u00f6r en stor del av trafiken under anslutningsf\u00f6rhandlingen. Kompression st\u00f6ds med hj\u00e4lp av biblioteken zlib, zstd och Brotli.\n<li class=\"l\"> St\u00f6d f\u00f6r det deterministiska alternativet f\u00f6r digitala signaturer ECDSA (Deterministic ECDSA, RFC 6979) har lagts till, d\u00e4r en hash HMAC-SHA256 av den privata nyckeln och den signerade meddelandetexten anv\u00e4nds ist\u00e4llet f\u00f6r en slumpm\u00e4ssig sekvens vid signaturgenerering. Detta g\u00f6r att man alltid f\u00e5r samma signatur vid olika signeringsoperationer, men utesluter l\u00e4ckage av data som kan anv\u00e4ndas f\u00f6r att kn\u00e4cka den privata nyckeln (den privata nyckeln kan kn\u00e4ckas om minst tv\u00e5 signaturer f\u00f6r olika data har genererats med en repetitiv slumpm\u00e4ssig sekvens).\n<li class=\"l\"> St\u00f6d f\u00f6r ut\u00f6kade varianter av digitala signaturer med offentlig nyckel Ed25519 och Ed448 har lagts till: Ed25519ctx, Ed25519ph och Ed448ph (RFC 8032).\n<li class=\"l\"> St\u00f6d f\u00f6r AES-GCM-SIV krypteringsl\u00e4get (RFC 8452) har lagts till, vilket kombinerar den h\u00f6ga prestandan av GCM-l\u00e4get (Galois\/Counter Mode) med motst\u00e5ndskraft mot l\u00e4ckage vid \u00e5teranv\u00e4ndning av slumpkod nonce.\n<li class=\"l\"> Funktionen f\u00f6r att generera Argon2-nycklar (RFC 9106) har implementerats, som vann en t\u00e4vling om hash-algoritmer f\u00f6r l\u00f6senord 2015. M\u00f6jlighet att anv\u00e4nda tr\u00e5dpooler har lagts till.\n<li class=\"l\"> St\u00f6d f\u00f6r hybridkryptering baserad p\u00e5 HPKE-mekanismen (Hybrid Public Key Encryption, RFC 9180) har lagts till, som kombinerar enkelheten i nyckel\u00f6verf\u00f6ring med h\u00f6g prestanda f\u00f6r symmetrisk kryptering (data krypteras med en snabb symmetrisk nyckel, medan sj\u00e4lva nyckeln krypteras med en l\u00e5ngsam asymmetrisk metod).\n<li class=\"l\"> I TLS har m\u00f6jligheten att anv\u00e4nda \"r\u00e5a\" (raw) offentliga nycklar (RFC 7250).\n<li class=\"l\"> St\u00f6d f\u00f6r mekanismen f\u00f6r snabb \u00f6ppning av TCP-anslutningar (TFO \u2014 TCP Fast Open, RFC 7413) har lagts till, vilket g\u00f6r det m\u00f6jligt att minska antalet steg f\u00f6r att etablera en anslutning genom att kombinera det f\u00f6rsta och andra steget i den klassiska 3-stegs processen f\u00f6r anslutnings\u00f6verenskommelse till en f\u00f6rfr\u00e5gan och m\u00f6jligg\u00f6r \u00f6verf\u00f6ring av data i det initiala steget av anslutningsuppr\u00e4ttandet.\n<li class=\"l\"> I TLS har st\u00f6d f\u00f6r pluggbara digitala signaturmodeller implementerats, vilket m\u00f6jligg\u00f6r anv\u00e4ndning av externa implementeringar av algoritmer, som f\u00f6r anv\u00e4ndning av kvantmotst\u00e5ndskraftiga algoritmer i TLS.\n<li class=\"l\"> I TLS 1.3 har st\u00f6d f\u00f6r skyddade elliptiska kurvor av typen Brainpool lagts till.\n<li class=\"l\"> St\u00f6d f\u00f6r SM4-XTS processorinstruktioner har lagts till.\n<li class=\"l\"> P\u00e5 Windows-plattformen har m\u00f6jligheten att anv\u00e4nda systemlagret f\u00f6r rotcertifikat implementerats (som standard avst\u00e4ngt). F\u00f6r att f\u00e5 tillg\u00e5ng till certifikaten i Windows-lagret f\u00f6resl\u00e5s URI \"org.openssl.winstore:\/\/\".     <\/ul>\n<p>K\u00e4lla: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=60174\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 \u043f\u0440\u043e\u0448\u043b\u044b\u0445 \u0432\u0435\u0442\u043e\u043a OpenSSL 3.1 \u0438 3.0 LTS \u043f\u0440\u043e\u0434\u043b\u0438\u0442\u0441\u044f \u0434\u043e \u043c\u0430\u0440\u0442\u0430 2025 \u0433\u043e\u0434\u0430 \u0438 \u0441\u0435\u043d\u0442\u044f\u0431\u0440\u044f 2026 \u0433\u043e\u0434\u0430 \u0441\u043e\u043e\u0442\u0432\u0435\u0442\u0441\u0442\u0432\u0435\u043d\u043d\u043e. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 \u0432\u0435\u0442\u043a\u0438 1.1.1 \u043f\u0440\u0435\u043a\u0440\u0430\u0449\u0435\u043d\u0430 \u0432 \u0441\u0435\u043d\u0442\u044f\u0431\u0440\u0435 \u044d\u0442\u043e\u0433\u043e \u0433\u043e\u0434\u0430. \u041a\u043e\u0434 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-111732","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.4 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/sv\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic\" \/>\n\t\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.4\" \/>\n\t\t<meta property=\"og:locale\" content=\"sv_SE\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u0412\u044b\u043f\u0443\u0441\u043a OpenSSL 3.2.0 \u0441 \u043a\u043b\u0438\u0435\u043d\u0442\u0441\u043a\u043e\u0439 \u043f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u043e\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/sv\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-11-24T13:10:17+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-11-24T13:10:17+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47Utgivningen av OpenSSL 3.2.0 med klientst\u00f6d f\u00f6r QUIC-protokollet | ProHoster","description":"Efter \u00e5tta m\u00e5naders utveckling har versionen av OpenSSL-biblioteket 3.2.0 med implementation av SSL\/TLS-protokoll och olika krypteringsalgoritmer formulerats. St\u00f6det f\u00f6r OpenSSL 3.2 kommer att forts\u00e4tta till den 23 november 2025.","canonical_url":"https:\/\/prohoster.info\/sv\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"sv_SE","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u0412\u044b\u043f\u0443\u0441\u043a OpenSSL 3.2.0 \u0441 \u043a\u043b\u0438\u0435\u043d\u0442\u0441\u043a\u043e\u0439 \u043f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u043e\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC | ProHoster","og:description":"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.","og:url":"https:\/\/prohoster.info\/sv\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-11-24T13:10:17+00:00","article:modified_time":"2023-11-24T13:10:17+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/sv\/wp-json\/wp\/v2\/posts\/111732","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/sv\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/sv\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/sv\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/sv\/wp-json\/wp\/v2\/comments?post=111732"}],"version-history":[{"count":1,"href":"https:\/\/prohoster.info\/sv\/wp-json\/wp\/v2\/posts\/111732\/revisions"}],"predecessor-version":[{"id":164419,"href":"https:\/\/prohoster.info\/sv\/wp-json\/wp\/v2\/posts\/111732\/revisions\/164419"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/sv\/wp-json\/wp\/v2\/media?parent=111732"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/sv\/wp-json\/wp\/v2\/categories?post=111732"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/sv\/wp-json\/wp\/v2\/tags?post=111732"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}