Mikrotik սկրիպտների հեռակա միացում Telegram v 2.0-ից

Շնորհավոր բոլորիս ուշացած տոնը։ Այս թեման ավելի լավն է այն, ինչ ես գրել էի դեռ 2016 թվականին, այստեղ.

Ընդհանուր առմամբ, շահագործման սկզբունքը չի փոխվել, միակ տարբերությունն այն է, որ այժմ այն ​​աշխատում է ակնթարթորեն, առանց ուշացման:

Մենք սկրիպտը վերբեռնում ենք Mikrotik-ում, փոխում ենք BotID-ը և ChatID-ը մեր սեփականի և ստեղծում դրա ժամանակացույցը: Սահմանեք «Սկսման ժամանակ» պարամետրը գործարկման համար (գործարկեք սկրիպտը գործարկման պահին):
«Ինտերվալ»՝ 00:00:00
Հակառակ դեպքում ամեն ինչ այնպես է, ինչպես եղել է։

Telegram-v2

:delay 10
:global mtIdentity [/system identity get name];
:global botID "botXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXX" ;
:global myChatID "YYYYYY" ;
:local chatId 0;
:local messageId 0;


:local parse do={
  :local startLoc ([:find $content $variable -1] + [:len $variable] + 2);
  :local commaLoc ([:find $content "," $startLoc] - 1 + 1);
  :local braceLoc ([:find $content "}" $startLoc] - 1 + 1);
  :local endLoc $commaLoc;
  :local startSymbol [:pick $content $startLoc]
  :if ($braceLoc != 0 and ($commaLoc = 0 or $braceLoc < $commaLoc)) do={
    :set endLoc $braceLoc;
  };
  :if ($startSymbol = "{") do={
    :set endLoc ($braceLoc + 1);
  };
  :if ($quotas = true) do={
    :set startLoc ($startLoc + 1);
    :set endLoc ($endLoc - 1);
  }
  :if ($endLoc < $startLoc) do={
    :set endLoc ($startLoc + 1);
  };
  :local message [:pick $content $startLoc $endLoc]
  #:log info $message;
  :return $message;
}


:while ( true ) do={
  :do {
    #:log info "https://api.telegram.org/$botID/getUpdates?offset=$messageId&limit=1&allowed_updates=message&timeout=60";
    :tool fetch url=("https://api.telegram.org/$botID/getUpdates?offset=$messageId&limit=1&allowed_updates=message&timeout=60") dst-path="getUpdates";
    :local content [/file get [/file find name=getUpdates] contents] ;
    #:log info $content;
    :if ([:len $content] > 30) do={
      :set messageId ([$parse content=$content variable="update_id"] + 1)
      :local message [$parse content=$content variable="text" quotas=true]
      :local chat [$parse content=$content variable="chat"]
      :local chatId [$parse content=$chat variable="id"]      
      
      :if (($chatId = $myChatID) and ([/system script find name=$message] != "")) do={
        :system script run $message;
      } else={
        :tool fetch url=("https://api.telegram.org/$botID/sendmessage?chat_id=$chatId&text=$mtIdentity: Unknown command: $message") keep-result=no
      }
    }
  } on-error={}
};

Մի քանի տարի օգտագործելուց հետո հայտնաբերվեց սխալ. անհայտ պատճառով թույլ Mikrotik-ը դադարեցնում է սցենարը, բայց ավելի հզորների վրա այն աշխատում է առանց կանգ առնելու։

Այդ նպատակների համար ես նետեցի WatchDog-ի հենակը: Այստեղ մենք փոխում ենք սկրիպտի անվանումը վերևում նշվածի: և վերագործարկման միջակայքը սահմանեք 5 րոպե: Ամեն 5 րոպեն մեկ մեր «հսկիչ շունը» ստուգելու է սցենարը և եթե այն չաշխատի, կաշխատի։

WatchDogT.me

:global scriptname "t.me"
:if ([:len [/system script job find script=$"scriptname"]] > 0) do={
:log info "$scriptname Already Running - killing old script before continuing"
:foreach counter in=[/system script job find script=$"scriptname"] do={
/system script job remove $counter
}
}
/system script run $scriptname

Դե, աղանդերի համար սցենարը վերցված է Mikrotik ֆորումից։
Ուղարկում է կարևոր թեմաներ մատյանից մեր զամբյուղ:

Մենք ավելացնում ենք սկրիպտը ժամանակացույցի համար և յուրաքանչյուր 5 րոպեն մեկ նշում ենք վերագործարկման միջակայքը, փոխում ենք BotID-ը և ChatID-ը մեր սեփականի:

Ծանուցել-մատյան

:global lastTime
:global output
:global mtIdentity [/system identity get name];
:global botID "botXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXX" ;
:global myChatID "YYYYYY" ;

:local LogGet [ :toarray [ /log find topics~"critical" || message~"login failure" || message~"[Ff]ailure" ] ] ;
:local LogtLineCount [ :len $LogGet ] ;
if ($LogtLineCount > 0) do={
   :local currentTime "$[ /log get [ :pick $LogGet ($LogtLineCount -1) ] time ]";
   :if ([:len $currentTime] = 10 ) do={
      :set currentTime [ :pick $currentTime 0 10 ];
   }
   :set output "$currentTime - $[/log get [ :pick $LogGet ($LogtLineCount-1) ] message ]";
   :if (([:len $lastTime] < 1) || (([:len $lastTime] > 0) && ($lastTime != $currentTime))) do={
      :set lastTime $currentTime ;
         :tool fetch url=("https://api.telegram.org/$botID/sendmessage?chat_id=$myChatID&text="$mtIdentity" :  $output") keep-result=no
   }
}

Մենք ստանում ենք արդյունքը.

Mikrotik սկրիպտների հեռակա միացում Telegram v 2.0-ից

Source: www.habr.com

Добавить комментарий