Keycloak๊ณผ ํ˜ธํ™˜๋˜๋Š” ID ๋ฐ ์•ก์„ธ์Šค ๊ด€๋ฆฌ ์„œ๋ฒ„์ธ Issuerd 0.1.17 ๋ฒ„์ „์ด ์ถœ์‹œ๋˜์—ˆ์Šต๋‹ˆ๋‹ค.

Issuerd 0.1.17์€ ID ๋ฐ ์•ก์„ธ์Šค ๊ด€๋ฆฌ(IAM) ์„œ๋ฒ„์ž…๋‹ˆ๋‹ค. OpenID Connect ๋ฐ OAuth 2.x ํ”„๋กœํ† ์ฝœ์„ ๊ตฌํ˜„ํ•˜๋ฉฐ, ๋ฐ์ดํ„ฐ ๋ชจ๋ธ ์ˆ˜์ค€์—์„œ Keycloak ํ”Œ๋žซํผ๊ณผ ํ˜ธํ™˜๋˜๊ณ  REST API๋ฅผ ๊ด€๋ฆฌํ•ฉ๋‹ˆ๋‹ค. ๊ตฌํ˜„๋œ ๊ธฐ๋Šฅ์œผ๋กœ๋Š” SSO, MFA(TOTP, WebAuthn/passkeys), LDAP ๋ฐ Kerberos/SPNEGO๋ฅผ ํ†ตํ•œ ์‚ฌ์šฉ์ž ํŽ˜๋”๋ ˆ์ด์…˜, ์™ธ๋ถ€ ID ๊ณต๊ธ‰์ž(OIDC, ์†Œ์…œ ๋„คํŠธ์›Œํฌ)๋ฅผ ํ†ตํ•œ ๋กœ๊ทธ์ธ, ์‚ฌ์šฉ์ž ์ •์˜ ๊ฐ€๋Šฅํ•œ ๋””์ž์ธ ๋ฐ ํ˜„์ง€ํ™” ๊ธฐ๋Šฅ์„ ๊ฐ–์ถ˜ ๋กœ๊ทธ์ธ ํŽ˜์ด์ง€, ๊ทธ๋ฆฌ๊ณ  ์ตœ์ดˆ ์‹คํ–‰ ์‹œ YAML์„ ํ†ตํ•œ ์„ ์–ธ์  ์ดˆ๊ธฐ ๊ตฌ์„ฑ ๋“ฑ์ด ์žˆ์Šต๋‹ˆ๋‹ค. ์ด ์„œ๋ฒ„๋Š” Rust๋กœ ์ž‘์„ฑ๋˜์—ˆ์œผ๋ฉฐ(์†์„ฑ ์ˆ˜์ค€์—์„œ ์•ˆ์ „ํ•˜์ง€ ์•Š์€ ์ฝ”๋“œ๋Š” ๊ธˆ์ง€๋จ), Apache 2.0 ๋ผ์ด์„ ์Šค์— ๋”ฐ๋ผ ๋ฐฐํฌ๋˜๊ณ , ํ†ตํ•ฉ ๊ด€๋ฆฌ ์ฝ˜์†”๊ณผ ์‚ฌ์šฉ์ž ์ฝ˜์†”์ด ํฌํ•จ๋œ ๋‹จ์ผ ๋ฐ”์ด๋„ˆ๋ฆฌ ํŒŒ์ผ๋กœ ์ œ๊ณต๋ฉ๋‹ˆ๋‹ค. ๋‹ค์Œ ํ”Œ๋žซํผ์šฉ ๋นŒ๋“œ๊ฐ€ ์ƒ์„ฑ๋ฉ๋‹ˆ๋‹ค. Linux, Windows ะธ macOS (amd64 ๋ฐ
arm64).

์ด ํ”„๋กœ์ ํŠธ์˜ ํ•ต์‹ฌ ํŠน์ง•์€ ์ง€์†์ ์ธ ๊ทœ์ • ์ค€์ˆ˜ ๊ฒ€์ฆ์ž…๋‹ˆ๋‹ค.
OpenID ์žฌ๋‹จ ๊ณต์‹ ์ ํ•ฉ์„ฑ ํ…Œ์ŠคํŠธ ์Šค์œ„ํŠธ(5.3.2)์ž…๋‹ˆ๋‹ค. ํ…Œ์ŠคํŠธ๋Š” ๊ฐ ๋ฆด๋ฆฌ์Šค๋งˆ๋‹ค ๊ฒฉ๋ฆฌ๋œ Docker ํ™˜๊ฒฝ์—์„œ CI๋ฅผ ํ†ตํ•ด ์ˆ˜ํ–‰๋ฉ๋‹ˆ๋‹ค. ๋ชจ๋“ˆ๋ณ„ ๊ฒฐ๊ณผ๋Š” ์ €์žฅ์†Œ์— ์ €์žฅ๋˜๋ฉฐ, ์ „์ฒด ๋ณด๊ณ ์„œ ํŒจํ‚ค์ง€๋Š” ์ฒจ๋ถ€ ํŒŒ์ผ์— ํฌํ•จ๋˜์–ด ์žˆ์Šต๋‹ˆ๋‹ค.
๊ฐ ๋ฆด๋ฆฌ์Šค๋งˆ๋‹ค Keycloak๊ณผ์˜ ๋™๋“ฑ์„ฑ์ด ์ผ๋ จ์˜ ํ…Œ์ŠคํŠธ๋ฅผ ํ†ตํ•ด ๊ฒ€์ฆ๋ฉ๋‹ˆ๋‹ค. ๊ณต์‹ ์ธ์ฆ์ด ์˜ˆ์ •๋˜์–ด ์žˆ์Šต๋‹ˆ๋‹ค.

AI ์—์ด์ „ํŠธ ์‹œ๋‚˜๋ฆฌ์˜ค์—์„œ ์ผ๋ฐ˜์ ์œผ๋กœ ์‚ฌ์šฉ๋˜๋Š” ํ”„๋กœํ† ์ฝœ์—๋Š” DPoP(RFC 9449, ๋ฒ ์–ด๋Ÿฌ ํ‚ค์— ํ† ํฐ ๋ฐ”์ธ๋”ฉ), ํ† ํฐ ๊ตํ™˜(RFC 8693, ํ† ํฐ ๊ตํ™˜ ์ค‘ ๊ถŒํ•œ ์ œํ•œ), CIBA(ํด๋ง ๋ชจ๋“œ, ์ž‘์—…์— ๋Œ€ํ•œ ์‚ฌ๋žŒ ํ™•์ธ)๊ฐ€ ์žˆ์Šต๋‹ˆ๋‹ค. PAR(RFC 9126), JAR(RFC 9101), JARM, RAR(RFC 9396), ๋™์  ํด๋ผ์ด์–ธํŠธ ๋“ฑ๋ก(RFC 7591/7592), ์žฅ์น˜ ์ธ์ฆ(RFC 8628)๋„ ์ง€์›๋ฉ๋‹ˆ๋‹ค. MS Active Directory์—์„œ 100๋งŒ ๋ช…์˜ ์‚ฌ์šฉ์ž๋ฅผ ์™„์ „ํžˆ ๊ฐ€์ ธ์˜ค๋Š” ๋ฐ ์•ฝ 30์ดˆ๊ฐ€ ์†Œ์š”๋ฉ๋‹ˆ๋‹ค.

์ถœ์ฒ˜ : opennet.ru

DDoS ๋ณดํ˜ธ, VPS VDS ์„œ๋ฒ„๊ฐ€ ์žˆ๋Š” ์‚ฌ์ดํŠธ๋ฅผ ์œ„ํ•œ ์•ˆ์ •์ ์ธ ํ˜ธ์ŠคํŒ… ๊ตฌ์ž… ๐Ÿ”ฅ DDoS ๊ณต๊ฒฉ ๋ฐฉ์ง€ ๊ธฐ๋Šฅ์ด ํƒ‘์žฌ๋œ ์•ˆ์ •์ ์ธ ์›น์‚ฌ์ดํŠธ ํ˜ธ์ŠคํŒ…, VPS ๋ฐ VDS ์„œ๋ฒ„๋ฅผ ๊ตฌ๋งคํ•˜์„ธ์š” | ProHoster