Issuerd 0.1.17์ ID ๋ฐ ์ก์ธ์ค ๊ด๋ฆฌ(IAM) ์๋ฒ์
๋๋ค. OpenID Connect ๋ฐ OAuth 2.x ํ๋กํ ์ฝ์ ๊ตฌํํ๋ฉฐ, ๋ฐ์ดํฐ ๋ชจ๋ธ ์์ค์์ Keycloak ํ๋ซํผ๊ณผ ํธํ๋๊ณ REST API๋ฅผ ๊ด๋ฆฌํฉ๋๋ค. ๊ตฌํ๋ ๊ธฐ๋ฅ์ผ๋ก๋ SSO, MFA(TOTP, WebAuthn/passkeys), LDAP ๋ฐ Kerberos/SPNEGO๋ฅผ ํตํ ์ฌ์ฉ์ ํ๋๋ ์ด์
, ์ธ๋ถ ID ๊ณต๊ธ์(OIDC, ์์
๋คํธ์ํฌ)๋ฅผ ํตํ ๋ก๊ทธ์ธ, ์ฌ์ฉ์ ์ ์ ๊ฐ๋ฅํ ๋์์ธ ๋ฐ ํ์งํ ๊ธฐ๋ฅ์ ๊ฐ์ถ ๋ก๊ทธ์ธ ํ์ด์ง, ๊ทธ๋ฆฌ๊ณ ์ต์ด ์คํ ์ YAML์ ํตํ ์ ์ธ์ ์ด๊ธฐ ๊ตฌ์ฑ ๋ฑ์ด ์์ต๋๋ค. ์ด ์๋ฒ๋ Rust๋ก ์์ฑ๋์์ผ๋ฉฐ(์์ฑ ์์ค์์ ์์ ํ์ง ์์ ์ฝ๋๋ ๊ธ์ง๋จ), Apache 2.0 ๋ผ์ด์ ์ค์ ๋ฐ๋ผ ๋ฐฐํฌ๋๊ณ , ํตํฉ ๊ด๋ฆฌ ์ฝ์๊ณผ ์ฌ์ฉ์ ์ฝ์์ด ํฌํจ๋ ๋จ์ผ ๋ฐ์ด๋๋ฆฌ ํ์ผ๋ก ์ ๊ณต๋ฉ๋๋ค. ๋ค์ ํ๋ซํผ์ฉ ๋น๋๊ฐ ์์ฑ๋ฉ๋๋ค. Linux, Windows ะธ macOS (amd64 ๋ฐ
arm64).
์ด ํ๋ก์ ํธ์ ํต์ฌ ํน์ง์ ์ง์์ ์ธ ๊ท์ ์ค์ ๊ฒ์ฆ์
๋๋ค.
OpenID ์ฌ๋จ ๊ณต์ ์ ํฉ์ฑ ํ
์คํธ ์ค์ํธ(5.3.2)์
๋๋ค. ํ
์คํธ๋ ๊ฐ ๋ฆด๋ฆฌ์ค๋ง๋ค ๊ฒฉ๋ฆฌ๋ Docker ํ๊ฒฝ์์ CI๋ฅผ ํตํด ์ํ๋ฉ๋๋ค. ๋ชจ๋๋ณ ๊ฒฐ๊ณผ๋ ์ ์ฅ์์ ์ ์ฅ๋๋ฉฐ, ์ ์ฒด ๋ณด๊ณ ์ ํจํค์ง๋ ์ฒจ๋ถ ํ์ผ์ ํฌํจ๋์ด ์์ต๋๋ค.
๊ฐ ๋ฆด๋ฆฌ์ค๋ง๋ค Keycloak๊ณผ์ ๋๋ฑ์ฑ์ด ์ผ๋ จ์ ํ
์คํธ๋ฅผ ํตํด ๊ฒ์ฆ๋ฉ๋๋ค. ๊ณต์ ์ธ์ฆ์ด ์์ ๋์ด ์์ต๋๋ค.
AI ์์ด์ ํธ ์๋๋ฆฌ์ค์์ ์ผ๋ฐ์ ์ผ๋ก ์ฌ์ฉ๋๋ ํ๋กํ ์ฝ์๋ DPoP(RFC 9449, ๋ฒ ์ด๋ฌ ํค์ ํ ํฐ ๋ฐ์ธ๋ฉ), ํ ํฐ ๊ตํ(RFC 8693, ํ ํฐ ๊ตํ ์ค ๊ถํ ์ ํ), CIBA(ํด๋ง ๋ชจ๋, ์์
์ ๋ํ ์ฌ๋ ํ์ธ)๊ฐ ์์ต๋๋ค. PAR(RFC 9126), JAR(RFC 9101), JARM, RAR(RFC 9396), ๋์ ํด๋ผ์ด์ธํธ ๋ฑ๋ก(RFC 7591/7592), ์ฅ์น ์ธ์ฆ(RFC 8628)๋ ์ง์๋ฉ๋๋ค. MS Active Directory์์ 100๋ง ๋ช
์ ์ฌ์ฉ์๋ฅผ ์์ ํ ๊ฐ์ ธ์ค๋ ๋ฐ ์ฝ 30์ด๊ฐ ์์๋ฉ๋๋ค.
์ถ์ฒ : opennet.ru
