Issuerd 0.1.17 ၏ ထုတ်ဝေမှု၊ Keycloak နှင့် တွဲဖက်အသုံးပြုနိုင်သော identity နှင့် access management server

Issuerd 0.1.17၊ identity and access management (IAM) server ကို ထုတ်ပြန်လိုက်ပါပြီ။ ၎င်းသည် OpenID Connect နှင့် OAuth 2.x protocols များကို အကောင်အထည်ဖော်ပြီး data model level တွင် Keycloak platform နှင့် တွဲဖက်အသုံးပြုနိုင်ကာ REST API ကို စီမံခန့်ခွဲပါသည်။ အကောင်အထည်ဖော်ထားသော features များတွင် SSO၊ MFA (TOTP၊ WebAuthn/passkeys)၊ LDAP နှင့် Kerberos/SPNEGO မှ user federation၊ external identity provider များ (OIDC၊ social networks) မှတစ်ဆင့် login ဝင်ခြင်း၊ စိတ်ကြိုက်ဒီဇိုင်းနှင့် localization ပါရှိသော login pages များနှင့် ပထမဆုံးစတင်ချိန်တွင် YAML မှ declarative initial configuration တို့ ပါဝင်သည်။ server ကို Rust ဖြင့်ရေးသားထားပြီး (attribute level တွင် unsafe code ကို တားမြစ်ထားသည်)၊ Apache 2.0 license အောက်တွင် ဖြန့်ဝေထားပြီး integrated administrative console နှင့် user console ပါရှိသော single, self-contained binary file အဖြစ် ပါရှိသည်။ Build များကို အောက်ပါ platform များအတွက် ထုတ်လုပ်ပေးသည်- Linux, Windows и macOS (amd64 နှင့်
arm64)။

စီမံကိန်း၏ အဓိကအင်္ဂါရပ်တစ်ခုမှာ လိုက်နာမှုရှိမရှိ စဉ်ဆက်မပြတ် စစ်ဆေးခြင်းဖြစ်သည်။
တရားဝင် OpenID Foundation Conformance Suite (5.3.2) စမ်းသပ်မှုအစုံ။ သီးခြား Docker ပတ်ဝန်းကျင်တွင် ထုတ်ဝေမှုတစ်ခုစီအတွက် CI တွင် စမ်းသပ်မှုပြုလုပ်သည်။ မော်ဂျူးတစ်ခုချင်းစီ၏ ရလဒ်များကို repository တွင် သိမ်းဆည်းထားပြီး အစီရင်ခံစာအပြည့်အစုံကို ပူးတွဲပါရှိသည်။
ထုတ်ဝေမှုတစ်ခုစီ။ Keycloak နှင့် ညီမျှမှုကို စမ်းသပ်မှုအစုံဖြင့် အတည်ပြုသည်။ တရားဝင်အသိအမှတ်ပြုလက်မှတ်ကို စီစဉ်ထားသည်။

AI agent scenarios များတွင် အသုံးများသော protocols များတွင် DPoP (RFC 9449၊ token binding to the bearer key)၊ token exchange (RFC 8693၊ token exchange အတွင်း privileges များကို ကန့်သတ်ခြင်း) နှင့် CIBA (polling mode၊ human confirmation of actions) တို့ ပါဝင်သည်။ PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), dynamic client registration (RFC 7591/7592) နှင့် device authorization (RFC 8628) တို့ကိုလည်း ပံ့ပိုးပေးပါသည်။ MS Active Directory မှ အသုံးပြုသူ ၁၀၀,၀၀၀ ကို အပြည့်အဝ import လုပ်ရန် စက္ကန့် ၃၀ ခန့် ကြာပါသည်။

source: opennet.ru

DDoS ကာကွယ်ရေး၊ VPS VDS ဆာဗာများပါသည့် ဆိုက်များအတွက် ယုံကြည်စိတ်ချရသော hosting ကို ဝယ်ယူပါ။ 🔥 DDoS ကာကွယ်မှု၊ VPS VDS ဆာဗာများပါရှိသော ယုံကြည်စိတ်ချရသော ဝဘ်ဆိုက် hosting ကို ဝယ်ယူပါ | ProHoster