Izdaja Issuerda 0.1.17, strežnika za upravljanje identitet in dostopa, združljivega s Keycloakom

Izdan je bil strežnik Issuerd 0.1.17 za upravljanje identitet in dostopa (IAM). Implementira protokola OpenID Connect in OAuth 2.x ter je združljiv s platformo Keycloak na ravni podatkovnega modela in upravlja REST API. Med implementirane funkcije spadajo SSO, MFA (TOTP, WebAuthn/gesla), zveza uporabnikov iz LDAP in Kerberos/SPNEGO, prijava prek zunanjih ponudnikov identitet (OIDC, družbena omrežja), prijavne strani s prilagodljivo zasnovo in lokalizacijo ter deklarativna začetna konfiguracija iz YAML ob prvem zagonu. Strežnik je napisan v Rustu (nevarna koda je prepovedana na ravni atributov), ​​distribuiran pod licenco Apache 2.0 in je na voljo kot ena sama, samostojna binarna datoteka z integrirano skrbniško konzolo in uporabniško konzolo. Gradnje so ustvarjene za naslednje platforme: Linux, Windows и macOS (sprememba 64 in
roka64).

Ključna značilnost projekta je nenehno preverjanje skladnosti.
Uradni testni paket OpenID Foundation Conformance Suite (5.3.2). Testiranje se izvaja v CI za vsako izdajo v izoliranem okolju Docker. Rezultati modul za modulom so shranjeni v repozitoriju, celoten paket poročil pa je priložen.
Vsaka izdaja. Pariteta s Keycloakom se preveri z nizom testov. Načrtovana je uradna certifikacija.

Protokoli, ki se pogosto uporabljajo v scenarijih agentov umetne inteligence, vključujejo DPoP (RFC 9449, vezava žetona na ključ nosilca), izmenjavo žetonov (RFC 8693, omejevanje privilegijev med izmenjavo žetonov) in CIBA (način anketiranja, človeška potrditev dejanj). Podprti so tudi PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), dinamična registracija odjemalcev (RFC 7591/7592) in avtorizacija naprav (RFC 8628). Celoten uvoz 100 uporabnikov iz imenika MS Active Directory traja približno 30 sekund.

Vir: opennet.ru

Kupite zanesljivo gostovanje za strani z DDoS zaščito, VPS VDS strežniki 🔥 Kupite zanesljivo spletno gostovanje z zaščito DDoS, VPS VDS strežniki | ProHoster