Mtoaji 0.1.17, seva ya usimamizi wa utambulisho na ufikiaji (IAM), imetolewa. Inatekeleza itifaki za OpenID Connect na OAuth 2.x na inaoana na jukwaa la Keycloak katika kiwango cha modeli ya data na inasimamia REST API. Vipengele vilivyotekelezwa ni pamoja na SSO, MFA (TOTP, WebAuthn/passkeys), shirikisho la watumiaji kutoka LDAP na Kerberos/SPNEGO, kuingia kupitia watoa huduma za utambulisho wa nje (OIDC, mitandao ya kijamii), kurasa za kuingia zenye muundo na ujanibishaji unaoweza kubinafsishwa, na usanidi wa awali wa kutangaza kutoka YAML kwenye uzinduzi wa kwanza. Seva imeandikwa kwa Rust (msimbo usio salama ni marufuku katika kiwango cha sifa), inasambazwa chini ya leseni ya Apache 2.0, na huja kama faili moja ya jozi iliyojitegemea yenye kiweko cha utawala kilichojumuishwa na kiweko cha mtumiaji. Miundo huzalishwa kwa mifumo ifuatayo: Linux, Windows и macOS (amd64 na
mkono64).
Kipengele muhimu cha mradi ni uthibitishaji endelevu wa kufuata sheria.
Kifurushi rasmi cha majaribio cha OpenID Foundation Conformance Suite (5.3.2). Upimaji unafanywa katika CI kwa kila toleo katika mazingira ya Docker yaliyotengwa. Matokeo ya moduli kwa moduli yanahifadhiwa kwenye hazina, na kifurushi kamili cha ripoti kimeambatishwa
Kila toleo. Usawa na Keycloak unathibitishwa na seti ya majaribio. Uthibitishaji rasmi umepangwa.
Itifaki zinazotumika sana katika matukio ya wakala wa AI ni pamoja na DPoP (RFC 9449, kufunga tokeni kwenye ufunguo wa kibebaji), ubadilishanaji wa tokeni (RFC 8693, kuzuia marupurupu wakati wa ubadilishanaji wa tokeni), na CIBA (hali ya kupigia kura, uthibitisho wa vitendo kwa binadamu). PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), usajili wa mteja unaobadilika (RFC 7591/7592), na uidhinishaji wa kifaa (RFC 8628) pia vinaungwa mkono. Uingizaji kamili wa watumiaji 100 kutoka Saraka Active ya MS huchukua takriban sekunde 30.
Chanzo: opennet.ru
