crypto-gost 库已发布,这是一个使用 Java 实现的 GOST 加密算法,无需任何额外依赖。与 Castle/Bouncy Castle 实现的 GOST 算法不同,crypto-gost 提高了 Kuznechik 算法的性能,解决了某些安全问题,并提供了无需深入密码学知识的简单封装。该代码采用宽松的许可协议,允许无限制地分发、修改和创作衍生作品。
支持的算法:
- GOST R 34.11-2012 (RFC 6986) — 哈希函数“Stribog” 256 位和 512 位。
- GOST R 34.12-2015 — 分组密码“Kuznechik”,256 位密钥。
- GOST R 34.13-2015 - 加密模式 CBC、CFB、CTR(GAMMA)、OFB;模拟插入(CMAC)。
- GOST R 34.10-2012 (RFC 7091) — 电子签名 256 位和 512 位。
- HMAC-Streebog(RFC 7836、HMAC-Streebog-256 和 HMAC-Streebog-512)。
- MGM(多线性伽罗瓦模式)是 Kuznechik(RFC 9058)的一种 AEAD 模式,与 OpenSSL 兼容。
- SCrypt(RFC 7914)是一种基于密码的密钥生成函数。
来源: opennet.ru
