Issuerd 0.1.17,一款身分識別和存取管理 (IAM) 伺服器,現已發布。它實作了 OpenID Connect 和 OAuth 2.x 協議,並在資料模型層面與 Keycloak 平台相容,同時管理 REST API。已實現的功能包括:單一登入 (SSO)、多因素身份驗證 (MFA)(TOTP、WebAuthn/密碼)、基於 LDAP 和 Kerberos/SPNEGO 的用戶聯合身份驗證、透過外部身分提供者(OIDC、社交網路)登入、可自訂設計和本地化的登入頁面,以及首次啟動時透過 YAML 進行聲明式設定。該伺服器使用 Rust 編寫(禁止在屬性層級編寫不安全程式碼),以 Apache 2.0 許可證發布,並以單一獨立的二進位檔案形式提供,整合了管理控制台和使用者控制台。支援以下平台的建置: Linux, Windows и macOS (amd64 和
arm64)。
該專案的一個關鍵特點是持續的合規性驗證。
官方 OpenID 基金會一致性測試套件 (5.3.2)。測試在持續整合 (CI) 中針對每個版本在隔離的 Docker 環境中執行。每個模組的測試結果都儲存在程式碼倉庫中,完整的報告包會附加到…
每次發布新版本,都會透過一系列測試驗證其與 Keycloak 的一致性。官方認證也在計畫中。
AI代理場景中常用的協定包括DPoP(RFC 9449,令牌綁定到持有者密鑰)、令牌交換(RFC 8693,令牌交換期間限制權限)和CIBA(輪詢模式,手動確認操作)。此外,也支援PAR(RFC 9126)、JAR(RFC 9101)、JARM、RAR(RFC 9396)、動態用戶端註冊(RFC 7591/7592)和裝置授權(RFC 8628)。從微軟Active Directory完整匯入100萬用戶大約需要30秒。
來源: opennet.ru
