Vrystelling van Uitgewer 0.1.17, Keycloak-versoenbare identiteits- en toegangsbestuurbediener

Uitgewer 0.1.17, 'n identiteits- en toegangsbestuur (IAM) bediener, is vrygestel. Dit implementeer die OpenID Connect en OAuth 2.x protokolle en is versoenbaar met die Keycloak platform op die datamodel vlak en bestuur die REST API. Geïmplementeerde kenmerke sluit in SSO, MFA (TOTP, WebAuthn/wagwoorde), gebruikersfederasie vanaf LDAP en Kerberos/SPNEGO, aanmelding via eksterne identiteitsverskaffers (OIDC, sosiale netwerke), aanmeldbladsye met aanpasbare ontwerp en lokalisering, en verklarende aanvanklike konfigurasie vanaf YAML met die eerste bekendstelling. Die bediener is geskryf in Rust (onveilige kode is verbode op die attribuut vlak), versprei onder die Apache 2.0 lisensie, en kom as 'n enkele, selfstandige binêre lêer met 'n geïntegreerde administratiewe konsole en gebruikerskonsole. Bouwerk word gegenereer vir die volgende platforms: Linux, Windows и macOS (amd64 en
arm64).

'n Belangrike kenmerk van die projek is deurlopende nakomingsverifikasie.
Die amptelike OpenID Foundation Conformance Suite (5.3.2) toetssuite. Toetsing word in CI uitgevoer vir elke vrystelling in 'n geïsoleerde Docker-omgewing. Module-vir-module resultate word in die bewaarplek gestoor, en die volledige verslagpakket is aangeheg.
Elke vrystelling. Pariteit met Keycloak word deur 'n stel toetse geverifieer. Amptelike sertifisering word beplan.

Protokolle wat algemeen in KI-agentscenario's gebruik word, sluit in DPoP (RFC 9449, tokenbinding aan die draersleutel), tokenuitruiling (RFC 8693, beperking van voorregte tydens tokenuitruiling) en CIBA (pollingmodus, menslike bevestiging van aksies). PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), dinamiese kliëntregistrasie (RFC 7591/7592) en toestelmagtiging (RFC 8628) word ook ondersteun. 'n Volledige invoer van 100 000 gebruikers vanaf MS Active Directory neem ongeveer 30 sekondes.

Bron: opennet.ru

Koop betroubare hosting vir werwe met DDoS-beskerming, VPS VDS-bedieners 🔥 Koop betroubare webwerfhosting met DDoS-beskerming, VPS VDS-bedieners | ProHoster