Emitent 0.1.17 buraxılışı, Keycloak ilə uyğun identifikasiya və giriş idarəetmə serveri

Şəxsiyyət və giriş idarəetmə (IAM) serveri olan 0.1.17 buraxılışı buraxıldı. OpenID Connect və OAuth 2.x protokollarını tətbiq edir və məlumat modeli səviyyəsində Keycloak platforması ilə uyğun gəlir və REST API-ni idarə edir. Tətbiq olunan xüsusiyyətlərə SSO, MFA (TOTP, WebAuthn/parol açarları), LDAP və Kerberos/SPNEGO-dan istifadəçi federasiyası, xarici şəxsiyyət provayderləri (OIDC, sosial şəbəkələr) vasitəsilə giriş, özelleştirilebilir dizayn və lokalizasiya ilə giriş səhifələri və ilk işə salmada YAML-dən deklarativ ilkin konfiqurasiya daxildir. Server Rust dilində yazılıb (təhlükəsiz kod atribut səviyyəsində qadağandır), Apache 2.0 lisenziyası altında paylanır və inteqrasiya olunmuş inzibati konsol və istifadəçi konsolu ilə tək, müstəqil ikili fayl kimi gəlir. Quruluşlar aşağıdakı platformalar üçün yaradılır: Linux, Windows и macOS (amd64 və
qol64).

Layihənin əsas xüsusiyyəti davamlı uyğunluq yoxlamasıdır.
Rəsmi OpenID Foundation Uyğunluq Dəsti (5.3.2) test dəsti. Test, hər buraxılış üçün təcrid olunmuş Docker mühitində CI-də aparılır. Modullar üzrə nəticələr depoda saxlanılır və tam hesabat paketi əlavə olunur.
Hər buraxılış. Keycloak ilə paritet bir sıra testlərlə təsdiqlənir. Rəsmi sertifikatlaşdırma planlaşdırılır.

Süni intellekt agent ssenarilərində tez-tez istifadə olunan protokollara DPoP (RFC 9449, tokenin daşıyıcı açara bağlanması), token mübadiləsi (RFC 8693, token mübadiləsi zamanı imtiyazların məhdudlaşdırılması) və CIBA (sorğu rejimi, hərəkətlərin insan tərəfindən təsdiqlənməsi) daxildir. PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), dinamik müştəri qeydiyyatı (RFC 7591/7592) və cihazın avtorizasiyası (RFC 8628) də dəstəklənir. MS Active Directory-dən 100 istifadəçinin tam idxalı təxminən 30 saniyə çəkir.

Mənbə: opennet.ru

DDoS mühafizəsi, VPS VDS serverləri olan saytlar üçün etibarlı hostinq alın 🔥 DDoS qorunması, VPS VDS serverləri ilə etibarlı veb sayt hostinqi alın | ProHoster