Issuerd 0.1.17-āĻāϰ āĻĒā§āϰāĻ•āĻžāĻļ, Keycloak-āϏāĻžāĻŽāĻžā§āϜāĻ¸ā§āϝāĻĒā§‚āĻ°ā§āĻŖ āĻĒāϰāĻŋāϚāϝāĻŧ āĻāĻŦāĻ‚ āĻ…ā§āϝāĻžāĻ•ā§āϏ⧇āϏ āĻŦā§āϝāĻŦāĻ¸ā§āĻĨāĻžāĻĒāύāĻž āϏāĻžāĻ°ā§āĻ­āĻžāϰ

Issuerd 0.1.17, āĻāĻ•āϟāĻŋ āφāχāĻĄā§‡āĻ¨ā§āϟāĻŋāϟāĻŋ āĻ…ā§āϝāĻžāĻ¨ā§āĻĄ āĻ…ā§āϝāĻžāĻ•ā§āϏ⧇āϏ āĻŽā§āϝāĻžāύ⧇āϜāĻŽā§‡āĻ¨ā§āϟ (IAM) āϏāĻžāĻ°ā§āĻ­āĻžāϰ, āĻĒā§āϰāĻ•āĻžāĻļ āĻ•āϰāĻž āĻšāϝāĻŧ⧇āϛ⧇āĨ¤ āĻāϟāĻŋ OpenID Connect āĻāĻŦāĻ‚ OAuth 2.x āĻĒā§āϰ⧋āĻŸā§‹āĻ•āϞ āĻĒā§āϰāϝāĻŧā§‹āĻ— āĻ•āϰ⧇ āĻāĻŦāĻ‚ āĻĄā§‡āϟāĻž āĻŽāĻĄā§‡āϞ āĻ¸ā§āϤāϰ⧇ Keycloak āĻĒā§āĻ˛ā§āϝāĻžāϟāĻĢāĻ°ā§āĻŽā§‡āϰ āϏāĻžāĻĨ⧇ āϏāĻžāĻŽāĻžā§āϜāĻ¸ā§āϝāĻĒā§‚āĻ°ā§āĻŖ āĻ“ REST API āĻĒāϰāĻŋāϚāĻžāϞāύāĻž āĻ•āϰ⧇āĨ¤ āĻŦāĻžāĻ¸ā§āϤāĻŦāĻžāϝāĻŧāĻŋāϤ āĻŦ⧈āĻļāĻŋāĻˇā§āĻŸā§āϝāϗ⧁āϞāĻŋāϰ āĻŽāĻ§ā§āϝ⧇ āϰāϝāĻŧ⧇āϛ⧇ SSO, MFA (TOTP, WebAuthn/passkeys), LDAP āĻāĻŦāĻ‚ Kerberos/SPNEGO āĻĨ⧇āϕ⧇ āĻŦā§āϝāĻŦāĻšāĻžāϰāĻ•āĻžāϰ⧀ āĻĢ⧇āĻĄāĻžāϰ⧇āĻļāύ, āĻŦāĻžāĻšā§āϝāĻŋāĻ• āĻĒāϰāĻŋāϚāϝāĻŧ āĻĒā§āϰāĻĻāĻžāύāĻ•āĻžāϰ⧀āĻĻ⧇āϰ (OIDC, āϏāĻžāĻŽāĻžāϜāĻŋāĻ• āύ⧇āϟāĻ“āϝāĻŧāĻžāĻ°ā§āĻ•) āĻŽāĻžāĻ§ā§āϝāĻŽā§‡ āϞāĻ—āχāύ, āĻ•āĻžāĻ¸ā§āϟāĻŽāĻžāχāϜāϝ⧋āĻ—ā§āϝ āĻĄāĻŋāϜāĻžāχāύ āĻ“ āĻ¸ā§āĻĨāĻžāύ⧀āϝāĻŧāĻ•āϰāĻŖ āϏāĻš āϞāĻ—āχāύ āĻĒ⧃āĻˇā§āĻ āĻž, āĻāĻŦāĻ‚ āĻĒā§āϰāĻĨāĻŽāĻŦāĻžāϰ āϚāĻžāϞ⧁ āĻ•āϰāĻžāϰ āϏāĻŽāϝāĻŧ YAML āĻĨ⧇āϕ⧇ āĻĄāĻŋāĻ•ā§āϞāĻžāϰ⧇āϟāĻŋāĻ­ āĻĒā§āϰāĻžāĻĨāĻŽāĻŋāĻ• āĻ•āύāĻĢāĻŋāĻ—āĻžāϰ⧇āĻļāύāĨ¤ āϏāĻžāĻ°ā§āĻ­āĻžāϰāϟāĻŋ Rust āĻ­āĻžāώāĻžāϝāĻŧ āϞ⧇āĻ–āĻž (āĻ…ā§āϝāĻžāĻŸā§āϰāĻŋāĻŦāĻŋāωāϟ āĻ¸ā§āϤāϰ⧇ āĻ…āύāĻŋāϰāĻžāĻĒāĻĻ āϕ⧋āĻĄ āύāĻŋāώāĻŋāĻĻā§āϧ), Apache 2.0 āϞāĻžāχāϏ⧇āĻ¨ā§āϏ⧇āϰ āĻ…āϧ⧀āύ⧇ āĻŦāĻŋāϤāϰāĻŖ āĻ•āϰāĻž āĻšāϝāĻŧ⧇āϛ⧇, āĻāĻŦāĻ‚ āĻāĻ•āϟāĻŋ āϏāĻŽāĻ¨ā§āĻŦāĻŋāϤ āĻĒā§āϰāĻļāĻžāϏāύāĻŋāĻ• āĻ•āύāϏ⧋āϞ āĻ“ āĻŦā§āϝāĻŦāĻšāĻžāϰāĻ•āĻžāϰ⧀ āĻ•āύāϏ⧋āϞ āϏāĻš āĻāĻ•āϟāĻŋ āĻāĻ•āĻ•, āĻ¸ā§āĻŦāϝāĻŧāĻ‚āϏāĻŽā§āĻĒā§‚āĻ°ā§āĻŖ āĻŦāĻžāχāύāĻžāϰāĻŋ āĻĢāĻžāχāϞ āĻšāĻŋāϏāĻžāĻŦ⧇ āφāϏ⧇āĨ¤ āύāĻŋāĻŽā§āύāϞāĻŋāĻ–āĻŋāϤ āĻĒā§āĻ˛ā§āϝāĻžāϟāĻĢāĻ°ā§āĻŽāϗ⧁āϞāĻŋāϰ āϜāĻ¨ā§āϝ āĻŦāĻŋāĻ˛ā§āĻĄ āϤ⧈āϰāĻŋ āĻ•āϰāĻž āĻšāϝāĻŧ: Linux, Windows и macOS (amd64 āĻāĻŦāĻ‚
arm64)āĨ¤

āĻĒā§āϰāĻ•āĻ˛ā§āĻĒāϟāĻŋāϰ āĻāĻ•āϟāĻŋ āĻĒā§āϰāϧāĻžāύ āĻŦ⧈āĻļāĻŋāĻˇā§āĻŸā§āϝ āĻšāϞ⧋ āĻ•ā§āϰāĻŽāĻžāĻ—āϤ āϏāĻŽā§āĻŽāϤāĻŋ āϝāĻžāϚāĻžāχāĻ•āϰāĻŖāĨ¤
āĻ…āĻĢāĻŋāϏāĻŋāϝāĻŧāĻžāϞ āĻ“āĻĒ⧇āύāφāχāĻĄāĻŋ āĻĢāĻžāωāĻ¨ā§āĻĄā§‡āĻļāύ āĻ•āύāĻĢāϰāĻŽā§‡āĻ¨ā§āϏ āĻ¸ā§āϝ⧁āϟ (5.3.2) āĻŸā§‡āĻ¸ā§āϟ āĻ¸ā§āϝ⧁āϟāĨ¤ āĻĒā§āϰāϤāĻŋāϟāĻŋ āϰāĻŋāϞāĻŋāĻœā§‡āϰ āϜāĻ¨ā§āϝ CI-āϤ⧇ āĻāĻ•āϟāĻŋ āĻŦāĻŋāĻšā§āĻ›āĻŋāĻ¨ā§āύ āĻĄāĻ•āĻžāϰ āĻĒāϰāĻŋāĻŦ⧇āĻļ⧇ āĻŸā§‡āĻ¸ā§āϟāĻŋāĻ‚ āĻ•āϰāĻž āĻšāϝāĻŧāĨ¤ āĻŽāĻĄāĻŋāωāϞ-āĻ­āĻŋāĻ¤ā§āϤāĻŋāĻ• āĻĢāϞāĻžāĻĢāϞ āϰāĻŋāĻĒā§‹āϜāĻŋāϟāϰāĻŋāϤ⧇ āϏāĻ‚āϰāĻ•ā§āώāĻŖ āĻ•āϰāĻž āĻšāϝāĻŧ, āĻāĻŦāĻ‚ āϏāĻŽā§āĻĒā§‚āĻ°ā§āĻŖ āϰāĻŋāĻĒā§‹āĻ°ā§āϟ āĻĒā§āϝāĻžāϕ⧇āϜāϟāĻŋ āϏāĻ‚āϝ⧁āĻ•ā§āϤ āĻ•āϰāĻž āĻšāϝāĻŧāĨ¤
āĻĒā§āϰāϤāĻŋāϟāĻŋ āϰāĻŋāϞāĻŋāĻœā§‡, āĻāĻ•āϗ⧁āĻšā§āĻ› āĻĒāϰ⧀āĻ•ā§āώāĻžāϰ āĻŽāĻžāĻ§ā§āϝāĻŽā§‡ Keycloak-āĻāϰ āϏāĻžāĻĨ⧇ āϏāĻŽāϤāĻž āϝāĻžāϚāĻžāχ āĻ•āϰāĻž āĻšāϝāĻŧāĨ¤ āφāύ⧁āĻˇā§āĻ āĻžāύāĻŋāĻ• āϏāĻžāĻ°ā§āϟāĻŋāĻĢāĻŋāϕ⧇āĻļāύ⧇āϰ āĻĒāϰāĻŋāĻ•āĻ˛ā§āĻĒāύāĻž āϰāϝāĻŧ⧇āϛ⧇āĨ¤

āĻāφāχ āĻāĻœā§‡āĻ¨ā§āϟ āϏāĻŋāύāĻžāϰāĻŋāĻ“āϤ⧇ āϏāĻžāϧāĻžāϰāĻŖāϤ āĻŦā§āϝāĻŦāĻšā§ƒāϤ āĻĒā§āϰ⧋āĻŸā§‹āĻ•āϞāϗ⧁āϞ⧋āϰ āĻŽāĻ§ā§āϝ⧇ āϰāϝāĻŧ⧇āϛ⧇ āĻĄāĻŋāĻĒāĻŋāĻ“āĻĒāĻŋ (RFC 9449, āĻŦ⧇āϝāĻŧāĻžāϰāĻžāϰ āϕ⧀-āĻāϰ āϏāĻžāĻĨ⧇ āĻŸā§‹āϕ⧇āύ āĻŦāĻžāχāĻ¨ā§āĻĄāĻŋāĻ‚), āĻŸā§‹āϕ⧇āύ āĻāĻ•ā§āϏāĻšā§‡āĻžā§āϜ (RFC 8693, āĻŸā§‹āϕ⧇āύ āĻŦāĻŋāύāĻŋāĻŽāϝāĻŧ⧇āϰ āϏāĻŽāϝāĻŧ āĻŦāĻŋāĻļ⧇āώāĻžāϧāĻŋāĻ•āĻžāϰ āϏ⧀āĻŽāĻžāĻŦāĻĻā§āϧ āĻ•āϰāĻž), āĻāĻŦāĻ‚ āϏāĻŋāφāχāĻŦāĻŋāĻ (āĻĒā§‹āϞāĻŋāĻ‚ āĻŽā§‹āĻĄ, āĻ•āĻžāĻœā§‡āϰ āϜāĻ¨ā§āϝ āĻŽāĻžāύ⧁āώ⧇āϰ āĻ…āύ⧁āĻŽā§‹āĻĻāύ)āĨ¤ āĻāĻ›āĻžāĻĄāĻŧāĻžāĻ“ āĻĒāĻŋāĻāφāϰ (RFC 9126), āĻœā§‡āĻāφāϰ (RFC 9101), āĻœā§‡āĻāφāϰāĻāĻŽ, āφāϰāĻāφāϰ (RFC 9396), āĻĄāĻžāχāύāĻžāĻŽāĻŋāĻ• āĻ•ā§āϞāĻžāϝāĻŧ⧇āĻ¨ā§āϟ āϰ⧇āϜāĻŋāĻ¸ā§āĻŸā§āϰ⧇āĻļāύ (RFC 7591/7592), āĻāĻŦāĻ‚ āĻĄāĻŋāĻ­āĻžāχāϏ āĻ…āĻĨāϰāĻžāχāĻœā§‡āĻļāύ (RFC 8628) āϏāĻŽāĻ°ā§āĻĨāĻŋāϤāĨ¤ āĻāĻŽāĻāϏ āĻ…ā§āϝāĻžāĻ•ā§āϟāĻŋāĻ­ āĻĄāĻŋāϰ⧇āĻ•ā§āϟāϰāĻŋ āĻĨ⧇āϕ⧇ ā§§,ā§Ļā§Ļ,ā§Ļā§Ļā§Ļ āĻŦā§āϝāĻŦāĻšāĻžāϰāĻ•āĻžāϰ⧀āϕ⧇ āϏāĻŽā§āĻĒā§‚āĻ°ā§āĻŖāϰ⧂āĻĒ⧇ āχāĻŽā§āĻĒā§‹āĻ°ā§āϟ āĻ•āϰāϤ⧇ āĻĒā§āϰāĻžāϝāĻŧ ā§Šā§Ļ āϏ⧇āϕ⧇āĻ¨ā§āĻĄ āϏāĻŽāϝāĻŧ āϞāĻžāϗ⧇āĨ¤

āωāĻ¤ā§āϏ: opennet.ru

DDoS āϏ⧁āϰāĻ•ā§āώāĻž, VPS VDS āϏāĻžāĻ°ā§āĻ­āĻžāϰ āϏāĻš āϏāĻžāχāϟāϗ⧁āϞāĻŋāϰ āϜāĻ¨ā§āϝ āύāĻŋāĻ°ā§āĻ­āϰāϝ⧋āĻ—ā§āϝ āĻšā§‹āĻ¸ā§āϟāĻŋāĻ‚ āĻ•āĻŋāύ⧁āύ đŸ”Ĩ DDoS āϏ⧁āϰāĻ•ā§āώāĻž āϏāĻš āύāĻŋāĻ°ā§āĻ­āϰāϝ⧋āĻ—ā§āϝ āĻ“āϝāĻŧ⧇āĻŦāϏāĻžāχāϟ āĻšā§‹āĻ¸ā§āϟāĻŋāĻ‚ āĻ•āĻŋāύ⧁āύ, VPS VDS āϏāĻžāĻ°ā§āĻ­āĻžāϰ | ProHoster