Κυκλοφόρησε ο Issuerd 0.1.17, ένας διακομιστής διαχείρισης ταυτοτήτων και πρόσβασης (IAM). Υλοποιεί τα πρωτόκολλα OpenID Connect και OAuth 2.x και είναι συμβατός με την πλατφόρμα Keycloak σε επίπεδο μοντέλου δεδομένων και διαχειρίζεται το REST API. Οι υλοποιημένες λειτουργίες περιλαμβάνουν SSO, MFA (TOTP, WebAuthn/κλειδιά πρόσβασης), ομοσπονδία χρηστών από LDAP και Kerberos/SPNEGO, σύνδεση μέσω εξωτερικών παρόχων ταυτοτήτων (OIDC, κοινωνικά δίκτυα), σελίδες σύνδεσης με προσαρμόσιμο σχεδιασμό και εντοπισμό και δηλωτική αρχική διαμόρφωση από YAML κατά την πρώτη εκκίνηση. Ο διακομιστής είναι γραμμένος σε Rust (απαγορεύεται ο μη ασφαλής κώδικας σε επίπεδο χαρακτηριστικού), διανέμεται με την άδεια Apache 2.0 και παρέχεται ως ένα ενιαίο, αυτοτελές δυαδικό αρχείο με ενσωματωμένη κονσόλα διαχείρισης και κονσόλα χρήστη. Δημιουργούνται εκδόσεις για τις ακόλουθες πλατφόρμες: Linux, Windows и macOS (amd64 και
βραχίονας 64).
Ένα βασικό χαρακτηριστικό του έργου είναι η συνεχής επαλήθευση συμμόρφωσης.
Η επίσημη σουίτα δοκιμών του OpenID Foundation Conformance Suite (5.3.2). Οι δοκιμές εκτελούνται σε CI για κάθε έκδοση σε ένα απομονωμένο περιβάλλον Docker. Τα αποτελέσματα ανά ενότητα αποθηκεύονται στο αποθετήριο και το πλήρες πακέτο αναφορών επισυνάπτεται στο
Κάθε έκδοση. Η ισοτιμία με το Keycloak επαληθεύεται από ένα σύνολο δοκιμών. Έχει προγραμματιστεί επίσημη πιστοποίηση.
Τα πρωτόκολλα που χρησιμοποιούνται συνήθως σε σενάρια πρακτόρων τεχνητής νοημοσύνης περιλαμβάνουν το DPoP (RFC 9449, σύνδεση διακριτικού στο κλειδί του κομιστή), την ανταλλαγή διακριτικών (RFC 8693, περιορισμός δικαιωμάτων κατά την ανταλλαγή διακριτικών) και το CIBA (λειτουργία polling, ανθρώπινη επιβεβαίωση ενεργειών). Υποστηρίζονται επίσης τα PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), δυναμική εγγραφή πελάτη (RFC 7591/7592) και εξουσιοδότηση συσκευής (RFC 8628). Μια πλήρης εισαγωγή 100 χρηστών από το MS Active Directory διαρκεί περίπου 30 δευτερόλεπτα.
Πηγή: opennet.ru
