ื”ืคืขืœื” ืžืจื—ื•ืง ืฉืœ ืกืงืจื™ืคื˜ื™ื ืฉืœ Mikrotik ืž-Telegram v 2.0

ื—ื’ ืฉืžื— ื•ืžืื•ื—ืจ ืœื›ื•ืœื. ื”ื ื•ืฉื ื”ื–ื” ื™ื•ืชืจ ื˜ื•ื‘ ื’ืจืกื” ืฉืœ ืžื” ืฉื›ืชื‘ืชื™ ื‘-2016 ื›ืืŸ.

ื‘ืื•ืคืŸ ื›ืœืœื™, ืขืงืจื•ืŸ ื”ืคืขื•ืœื” ืœื ื”ืฉืชื ื”, ื”ื”ื‘ื“ืœ ื”ื™ื—ื™ื“ ื”ื•ื ืฉืขื›ืฉื™ื• ื–ื” ืขื•ื‘ื“ ื‘ืื•ืคืŸ ืžื™ื™ื“ื™ ืœืœื ื“ื™ื—ื•ื™.

ืื ื—ื ื• ืžืขืœื™ื ืืช ื”ืกืงืจื™ืคื˜ ืœ-Mikrotik, ืžืฉื ื™ื ืืช ื”-BotID ื•ื”-ChatID ืœืฉืœื ื• ื•ื™ื•ืฆืจื™ื ืœื• ืœื•ื— ื–ืžื ื™ื. ื”ื’ื“ืจ ืืช ื”ืคืจืžื˜ืจ "ื–ืžืŸ ื”ืชื—ืœื”" ืœื”ืคืขืœื” (ื”ืคืขืœ ืืช ื”ืกืงืจื™ืคื˜ ื‘ืขืช ื”ื”ืคืขืœื”.)
"ืžืจื•ื•ื—": 00:00:00
ืื—ืจืช ื”ื›ืœ ื›ืžื• ืฉื”ื™ื”.

ื˜ืœื’ืจื-v2

:delay 10
:global mtIdentity [/system identity get name];
:global botID "botXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXX" ;
:global myChatID "YYYYYY" ;
:local chatId 0;
:local messageId 0;


:local parse do={
  :local startLoc ([:find $content $variable -1] + [:len $variable] + 2);
  :local commaLoc ([:find $content "," $startLoc] - 1 + 1);
  :local braceLoc ([:find $content "}" $startLoc] - 1 + 1);
  :local endLoc $commaLoc;
  :local startSymbol [:pick $content $startLoc]
  :if ($braceLoc != 0 and ($commaLoc = 0 or $braceLoc < $commaLoc)) do={
    :set endLoc $braceLoc;
  };
  :if ($startSymbol = "{") do={
    :set endLoc ($braceLoc + 1);
  };
  :if ($quotas = true) do={
    :set startLoc ($startLoc + 1);
    :set endLoc ($endLoc - 1);
  }
  :if ($endLoc < $startLoc) do={
    :set endLoc ($startLoc + 1);
  };
  :local message [:pick $content $startLoc $endLoc]
  #:log info $message;
  :return $message;
}


:while ( true ) do={
  :do {
    #:log info "https://api.telegram.org/$botID/getUpdates?offset=$messageId&limit=1&allowed_updates=message&timeout=60";
    :tool fetch url=("https://api.telegram.org/$botID/getUpdates?offset=$messageId&limit=1&allowed_updates=message&timeout=60") dst-path="getUpdates";
    :local content [/file get [/file find name=getUpdates] contents] ;
    #:log info $content;
    :if ([:len $content] > 30) do={
      :set messageId ([$parse content=$content variable="update_id"] + 1)
      :local message [$parse content=$content variable="text" quotas=true]
      :local chat [$parse content=$content variable="chat"]
      :local chatId [$parse content=$chat variable="id"]      
      
      :if (($chatId = $myChatID) and ([/system script find name=$message] != "")) do={
        :system script run $message;
      } else={
        :tool fetch url=("https://api.telegram.org/$botID/sendmessage?chat_id=$chatId&text=$mtIdentity: Unknown command: $message") keep-result=no
      }
    }
  } on-error={}
};

ืœืื—ืจ ื›ืžื” ืฉื ื™ื ืฉืœ ืฉื™ืžื•ืฉ, ื”ืชื’ืœื” ื‘ืื’: ืžืกื™ื‘ื” ืœื ื™ื“ื•ืขื”, Mikrotik ื—ืœืฉ ืขื•ืฆืจ ืืช ื”ืกืงืจื™ืคื˜, ืื‘ืœ ื‘ื—ื–ืงื™ื ื™ื•ืชืจ ื–ื” ืขื•ื‘ื“ ื‘ืœื™ ืœื”ืคืกื™ืง.

ืœืžื˜ืจื•ืช ืืœื•, ื–ืจืงืชื™ ืืช ืงื‘ ื”-WatchDog. ื›ืืŸ ืื ื• ืžืฉื ื™ื ืืช ืฉื ื”ืชืกืจื™ื˜ ืœื–ื” ืฉืฆื•ื™ืŸ ืœืžืขืœื”. ื•ื”ื’ื“ืจ ืืช ืžืจื•ื•ื— ื”ื”ืคืขืœื” ืžื—ื“ืฉ ืœ-5 ื“ืงื•ืช. ื›ืœ 5 ื“ืงื•ืช "ื›ืœื‘ ื”ืฉืžื™ืจื”" ืฉืœื ื• ื™ื‘ื“ื•ืง ืืช ื”ืชืกืจื™ื˜ ื•ืื ื”ื•ื ืœื ืขื•ื‘ื“, ื”ื•ื ื™ืจื™ืฅ ืื•ืชื•.

WatchDogT.me

:global scriptname "t.me"
:if ([:len [/system script job find script=$"scriptname"]] > 0) do={
:log info "$scriptname Already Running - killing old script before continuing"
:foreach counter in=[/system script job find script=$"scriptname"] do={
/system script job remove $counter
}
}
/system script run $scriptname

ื•ื‘ื›ืŸ, ืœืงื™ื ื•ื—, ื”ืชืกืจื™ื˜ ื ืœืงื— ืžืคื•ืจื•ื ืžื™ืงืจื•ื˜ื™ืง.
ืฉื•ืœื— ื ื•ืฉืื™ื ื—ืฉื•ื‘ื™ื ืžื”ื™ื•ืžืŸ ืœืขื’ืœื” ืฉืœื ื•.

ืื ื• ืžื•ืกื™ืคื™ื ืืช ื”ืกืงืจื™ืคื˜ ืœืชื–ืžื•ืŸ ื•ืžืฆื™ื™ื ื™ื ืืช ืžืจื•ื•ื— ื”ื”ืคืขืœื” ืžื—ื“ืฉ ื›ืœ 5 ื“ืงื•ืช, ืžืฉื ื™ื ืืช BotID ื•-ChatID ืœืฉืœื ื•.

ื™ื•ืžืŸ ื”ื•ื“ืขื•ืช

:global lastTime
:global output
:global mtIdentity [/system identity get name];
:global botID "botXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXX" ;
:global myChatID "YYYYYY" ;

:local LogGet [ :toarray [ /log find topics~"critical" || message~"login failure" || message~"[Ff]ailure" ] ] ;
:local LogtLineCount [ :len $LogGet ] ;
if ($LogtLineCount > 0) do={
   :local currentTime "$[ /log get [ :pick $LogGet ($LogtLineCount -1) ] time ]";
   :if ([:len $currentTime] = 10 ) do={
      :set currentTime [ :pick $currentTime 0 10 ];
   }
   :set output "$currentTime - $[/log get [ :pick $LogGet ($LogtLineCount-1) ] message ]";
   :if (([:len $lastTime] < 1) || (([:len $lastTime] > 0) && ($lastTime != $currentTime))) do={
      :set lastTime $currentTime ;
         :tool fetch url=("https://api.telegram.org/$botID/sendmessage?chat_id=$myChatID&text="$mtIdentity" :  $output") keep-result=no
   }
}

ืื ื—ื ื• ืžืงื‘ืœื™ื ืืช ื”ืชื•ืฆืื”:

ื”ืคืขืœื” ืžืจื—ื•ืง ืฉืœ ืกืงืจื™ืคื˜ื™ื ืฉืœ Mikrotik ืž-Telegram v 2.0

ืžืงื•ืจ: www.habr.com

ื”ื•ืกืคืช ืชื’ื•ื‘ื”