Эмитенттин 0.1.17 версиясынын чыгарылышы, Keycloak менен шайкеш келген идентификация жана кирүүнү башкаруу сервери

0.1.17 эмитенти, идентификацияны жана кирүүнү башкаруу (IAM) сервери чыгарылды. Ал OpenID Connect жана OAuth 2.x протоколдорун ишке ашырат жана маалымат моделинин деңгээлинде Keycloak платформасы менен шайкеш келет жана REST API'син башкарат. Ишке ашырылган функцияларга SSO, MFA (TOTP, WebAuthn/passkeys), LDAP жана Kerberos/SPNEGO'дон колдонуучулар федерациясы, тышкы идентификация провайдерлери аркылуу кирүү (OIDC, социалдык тармактар), ыңгайлаштырылуучу дизайн жана локализация менен кирүү баракчалары жана биринчи ишке киргизүүдө YAML'ден декларативдик баштапкы конфигурация кирет. Сервер Rust тилинде жазылган (атрибут деңгээлинде кооптуу кодго тыюу салынат), Apache 2.0 лицензиясы боюнча таратылат жана интеграцияланган административдик консолу жана колдонуучу консолу бар бирдиктүү, өзүнчө бинардык файл катары келет. Курулуштар төмөнкү платформалар үчүн түзүлөт: Linux, Windows и macOS (amd64 жана
кол64).

Долбоордун негизги өзгөчөлүгү - шайкештикти үзгүлтүксүз текшерүү.
Расмий OpenID Foundation Conformance Suite (5.3.2) тесттик топтому. Тесттөө ар бир чыгарылыш үчүн обочолонгон Docker чөйрөсүндө CIде жүргүзүлөт. Модуль боюнча жыйынтыктар репозиторийде сакталат жана толук отчеттук пакет тиркелет
Ар бир чыгарылыш. Keycloak менен паритет бир катар тесттер менен текшерилет. Расмий сертификациялоо пландаштырылууда.

Жасалма интеллект агентинин сценарийлеринде кеңири колдонулган протоколдорго DPoP (RFC 9449, токенди алып жүрүүчү ачкычка байлоо), токен алмашуу (RFC 8693, токен алмашуу учурунда артыкчылыктарды чектөө) жана CIBA (суралоо режими, аракеттерди адам тарабынан ырастоо) кирет. PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), кардарларды динамикалык каттоо (RFC 7591/7592) жана түзмөктү авторизациялоо (RFC 8628) да колдоого алынат. MS Active Directory'ден 100 000 колдонуучуну толук импорттоо болжол менен 30 секундду талап кылат.

Source: opennet.ru

DDoS коргоосу, VPS VDS серверлери бар сайттар үчүн ишенимдүү хостинг сатып алыңыз 🔥 DDoS коргоосу, VPS VDS серверлери бар ишенимдүү веб-сайт хостингин сатып алыңыз | ProHoster