Izlaidums Issuerd 0.1.17, ar Keycloak saderīgs identitātes un piekļuves pārvaldības serveris

Ir izlaists identitātes un piekļuves pārvaldÄ«bas (IAM) serveris — 0.1.17. izdevums. Tas ievieÅ” OpenID Connect un OAuth 2.x protokolus un ir saderÄ«gs ar Keycloak platformu datu modeļa lÄ«menÄ«, kā arÄ« pārvalda REST API. Ieviestās funkcijas ietver SSO, MFA (TOTP, WebAuthn/atslēgas), lietotāju federāciju no LDAP un Kerberos/SPNEGO, pieteikÅ”anos, izmantojot ārējos identitātes nodroÅ”inātājus (OIDC, sociālie tÄ«kli), pieteikÅ”anās lapas ar pielāgojamu dizainu un lokalizāciju, kā arÄ« deklaratÄ«vu sākotnējo konfigurāciju no YAML pirmās palaiÅ”anas laikā. Serveris ir rakstÄ«ts Rust valodā (nedroÅ”s kods ir aizliegts atribÅ«tu lÄ«menÄ«), tiek izplatÄ«ts saskaņā ar Apache 2.0 licenci un ir pieejams kā viens, patstāvÄ«gs binārais fails ar integrētu administratÄ«vo konsoli un lietotāja konsoli. Versijas tiek Ä£enerētas Ŕādām platformām: Linux, Windows Šø macOS (amd64 un
roka64).

Projekta galvenā iezīme ir nepārtraukta atbilstības pārbaude.
Oficiālā OpenID Foundation Conformance Suite (5.3.2) testēŔanas komplekts. TestēŔana tiek veikta CI katram laidienam izolētā Docker vidē. Rezultāti pa moduļiem tiek glabāti repozitorijā, un pilna atskaites pakotne ir pievienota.
Katrā laidienā. Atbilstība ar Keycloak tiek pārbaudīta ar testu kopumu. Ir plānota oficiāla sertifikācija.

Protokoli, kas parasti tiek izmantoti mākslÄ«gā intelekta aÄ£entu scenārijos, ietver DPoP (RFC 9449, marÄ·iera saistīŔana ar nesēja atslēgu), marÄ·iera apmaiņu (RFC 8693, privilēģiju ierobežoÅ”ana marÄ·iera apmaiņas laikā) un CIBA (aptaujas režīms, cilvēka darbÄ«bu apstiprinājums). Tiek atbalstÄ«ti arÄ« PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), dinamiskā klienta reÄ£istrācija (RFC 7591/7592) un ierÄ«ces autorizācija (RFC 8628). PilnÄ«ga 100 000 lietotāju importēŔana no MS Active Directory aizņem aptuveni 30 sekundes.

Avots: opennet.ru

Iegādājieties uzticamu mitināŔanu vietnēm ar DDoS aizsardzÄ«bu, VPS VDS serveriem šŸ”„ Iegādājieties uzticamu tÄ«mekļa vietņu mitināŔanu ar DDoS aizsardzÄ«bu, VPS VDS serveriem | ProHoster