Utgiver 0.1.17, en identitets- og tilgangsadministrasjonsserver (IAM), er utgitt. Den implementerer OpenID Connect- og OAuth 2.x-protokollene og er kompatibel med Keycloak-plattformen på datamodellnivå og administrerer REST API. Implementerte funksjoner inkluderer SSO, MFA (TOTP, WebAuthn/passord), brukerføderasjon fra LDAP og Kerberos/SPNEGO, pålogging via eksterne identitetsleverandører (OIDC, sosiale nettverk), påloggingssider med tilpassbar design og lokalisering, og deklarativ initial konfigurasjon fra YAML ved første oppstart. Serveren er skrevet i Rust (usikker kode er forbudt på attributtnivå), distribuert under Apache 2.0-lisensen, og leveres som en enkelt, selvstendig binærfil med en integrert administrativ konsoll og brukerkonsoll. Bygg genereres for følgende plattformer: Linux, Windows и macOS (amd64 og
arm64).
En sentral funksjon i prosjektet er kontinuerlig samsvarsverifisering.
Den offisielle OpenID Foundation Conformance Suite (5.3.2) testpakken. Testingen utføres i CI for hver utgivelse i et isolert Docker-miljø. Modul-for-modul-resultater lagres i depotet, og hele rapportpakken er vedlagt.
Hver utgivelse. Paritet med Keycloak verifiseres av et sett med tester. Offisiell sertifisering er planlagt.
Protokoller som ofte brukes i AI-agentscenarier inkluderer DPoP (RFC 9449, tokenbinding til bærernøkkelen), tokenutveksling (RFC 8693, begrensning av rettigheter under tokenutveksling) og CIBA (pollingmodus, menneskelig bekreftelse av handlinger). PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), dynamisk klientregistrering (RFC 7591/7592) og enhetsautorisasjon (RFC 8628) støttes også. En full import av 100 000 brukere fra MS Active Directory tar omtrent 30 sekunder.
Kilde: opennet.ru
