Випуск Issuerd 0.1.17, Keycloak-сумісного сервера керування ідентифікацією та доступом

Опубліковано випуск Issuerd 0.1.17 — сервера керування ідентифікацією та доступом (IAM), що реалізує протоколи OpenID Connect та OAuth 2.x та сумісного з платформою Keycloak на рівні моделі даних та керуючого REST API. Реалізовані SSO, MFA (TOTP, WebAuthn/passkeys), федерація користувачів з LDAP та Kerberos/SPNEGO, вхід через зовнішніх провайдерів ідентифікації (OIDC, соцмережі), сторінки входу з налаштованим оформленням та локалізацією, декларативна початкова конфігурація з YAM. Сервер написаний на Rust (unsafe-код заборонений на рівні атрибутів), розповсюджується під ліцензією Apache 2.0 і постачається одним самодостатнім бінарним файлом, в який вбудовано адміністративну консоль та консоль користувача. Складання формуються для платформ Linux, Windows и macOS (amd64 та
arm64).

Ключова особливість проекту – безперервна перевірка відповідності
офіційний набір тестів OpenID Foundation Conformance Suite (5.3.2). Тестування проводиться в CI для кожного релізу у ізольованому docker-оточенні. Помодульні результати зберігаються в репозиторії, а повний пакет звітів прикладається до
кожному релізу. Паритет із Keycloak контролюється набором тестів. У планах проходження офіційної сертифікації.

З протоколів, затребуваних у сценаріях з AI-агентами, реалізовані DPoP (RFC 9449, прив'язка токена до ключа пред'явника), обмін токенами (RFC 8693, звуження повноважень при обміні токена) та CIBA (режим poll, підтвердження дій людиною). Також підтримуються PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), динамічна реєстрація клієнтів (RFC 7591/7592), авторизація пристроїв (RFC 8628). Повний імпорт 100 тисяч користувачів із MS Active Directory займає близько 30 секунд.

Джерело: opennet.ru

Купити надійний хостинг для сайтів із захистом від DDoS, VPS VDS сервери 🔥 Купити надійний хостинг для сайтів із захистом від DDoS, VPS VDS сервери | ProHoster