Issuerd 0.1.17,一款身份和访问管理 (IAM) 服务器,现已发布。它实现了 OpenID Connect 和 OAuth 2.x 协议,并在数据模型层面与 Keycloak 平台兼容,同时管理 REST API。已实现的功能包括:单点登录 (SSO)、多因素身份验证 (MFA)(TOTP、WebAuthn/密码)、基于 LDAP 和 Kerberos/SPNEGO 的用户联合身份验证、通过外部身份提供商(OIDC、社交网络)登录、可自定义设计和本地化的登录页面,以及首次启动时通过 YAML 进行声明式初始配置。该服务器使用 Rust 编写(禁止在属性级别编写不安全代码),以 Apache 2.0 许可证发布,并以单个独立的二进制文件形式提供,集成了管理控制台和用户控制台。支持以下平台的构建: Linux, Windows и macOS (amd64 和
arm64)。
该项目的一个关键特点是持续的合规性验证。
官方 OpenID 基金会一致性测试套件 (5.3.2)。测试在持续集成 (CI) 中针对每个版本在隔离的 Docker 环境中执行。每个模块的测试结果都存储在代码仓库中,完整的报告包会附加到……
每次发布新版本,都会通过一系列测试验证其与 Keycloak 的一致性。官方认证也在计划之中。
AI代理场景中常用的协议包括DPoP(RFC 9449,令牌绑定到持有者密钥)、令牌交换(RFC 8693,令牌交换期间限制权限)和CIBA(轮询模式,人工确认操作)。此外,还支持PAR(RFC 9126)、JAR(RFC 9101)、JARM、RAR(RFC 9396)、动态客户端注册(RFC 7591/7592)和设备授权(RFC 8628)。从微软Active Directory完整导入100万用户大约需要30秒。
来源: opennet.ru
