Выпуск Issuerd 0.1.17, Keycloak-сумяшчальнага сервера кіравання ідэнтыфікацыяй і доступам

Апублікаваны выпуск Issuerd 0.1.17 – сервера кіравання ідэнтыфікацыяй і доступам (IAM), які рэалізуе пратаколы OpenID Connect і OAuth 2.x і сумяшчальнага з платформай Keycloak на ўзроўні мадэлі дадзеных і кіраўніка REST API. Рэалізаваны SSO, MFA (TOTP, WebAuthn/passkeys), федэрацыя карыстачоў з LDAP і Kerberos/SPNEGO, уваход праз вонкавых правайдэраў ідэнтыфікацыі (OIDC, сацсеткі), старонкі ўваходу з наладжвальным афармленнем і лакалізацыяй, дэкларатыўная першапачатковая канфігурацыя з YAM. Сервер напісаны на Rust (unsafe-код забаронены на ўзроўні атрыбутаў), распаўсюджваецца пад ліцэнзіяй Apache 2.0 і пастаўляецца адным самадастатковым бінарным файлам, у які ўбудаваны адміністрацыйная кансоль і кансоль карыстача. Зборкі фармуюцца для платформ Linux, Windows и macOS (amd64 і
arm64).

Ключавая асаблівасць праекта - бесперапынная праверка адпаведнасці
афіцыйнаму набору тэстаў OpenID Foundation Conformance Suite (5.3.2). Тэставанне праводзіцца ў CI для кожнага рэлізу ў ізаляваным docker-акружэнні. Памодульныя вынікі захоўваюцца ў рэпазітары, а поўны пакет справаздач прыкладваецца да
кожнаму рэлізу. Парытэт з Keycloak кантралюецца наборам тэстаў. У планах праходжанне афіцыйнай сертыфікацыі.

З пратаколаў, запатрабаваных у сцэнарах з AI-агентамі, рэалізаваны DPoP (RFC 9449, прывязка токена да ключа прад'яўніка), абмен токенамі (RFC 8693, звужэнне паўнамоцтваў пры абмене токена) і CIBA (рэжым poll, пацверджанне дзеянняў чалавекам). Таксама падтрымліваюцца PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), дынамічная рэгістрацыя кліентаў (RFC 7591/7592), аўтарызацыя прылад (RFC 8628). Поўны імпарт 100 карыстальнікаў з MS Active Directory займае каля 30 секунд.

Крыніца: opennet.ru

Купіць надзейны хостынг для сайтаў з абаронай ад DDoS, VPS VDS серверы 🔥 Купіць надзейны хостынг для сайтаў з абаронай ад DDoS, VPS VDS серверы | ProHoster