מהדורת Issuerd 0.1.17, שרת ניהול זהויות וגישה תואם Keycloak

גרסה 0.1.17, שרת ניהול זהויות וגישה (IAM), שוחרר. הוא מיישם את הפרוטוקולים OpenID Connect ו-OAuth 2.x ותואם לפלטפורמת Keycloak ברמת מודל הנתונים ומנהל את REST API. התכונות המיושמות כוללות SSO, MFA (TOTP, WebAuthn/passkeys), איחוד משתמשים מ-LDAP ו-Kerberos/SPNEGO, כניסה דרך ספקי זהויות חיצוניים (OIDC, רשתות חברתיות), דפי כניסה עם עיצוב ולוקליזציה הניתנים להתאמה אישית, ותצורה ראשונית הצהרתית מ-YAML בעת ההפעלה הראשונה. השרת כתוב ב-Rust (קוד לא בטוח אסור ברמת התכונה), מופץ תחת רישיון Apache 2.0, ומגיע כקובץ בינארי יחיד ועצמאי עם קונסולת ניהול וקונסולת משתמש משולבת. גרסאות build נוצרות עבור הפלטפורמות הבאות: Linux, Windows и macOS (amd64 ו-
זרוע64).

מאפיין מרכזי של הפרויקט הוא אימות תאימות מתמשך.
חבילת הבדיקות הרשמית של OpenID Foundation Conformance Suite (5.3.2). הבדיקות מתבצעות ב-CI עבור כל מהדורה בסביבת Docker מבודדת. תוצאות מודול אחר מודול מאוחסנות במאגר, וחבילת הדוח המלאה מצורפת ל...
כל מהדורה. שוויון עם Keycloak מאומת על ידי סדרה של בדיקות. הסמכה רשמית מתוכננת.

פרוטוקולים נפוצים בתרחישי סוכני בינה מלאכותית כוללים DPoP (RFC 9449, קישור אסימון למפתח נושא), החלפת אסימון (RFC 8693, הגבלת הרשאות במהלך החלפת אסימון) ו-CIBA (מצב סקר, אישור אנושי של פעולות). PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), רישום לקוח דינמי (RFC 7591/7592) ואישור התקן (RFC 8628) נתמכים גם כן. ייבוא ​​מלא של 100 משתמשים מ-MS Active Directory אורך כ-30 שניות.

מקור: OpenNet.ru

קנה אירוח אמין לאתרים עם הגנת DDoS, שרתי VPS VDS 🔥 קנה אחסון אתרים אמין עם הגנת DDoS, שרתי VPS VDS | ProHoster