Išleista „Issuerd 0.1.17“ versija – su „Keycloak“ suderinamas tapatybės ir prieigos valdymo serveris

Išleistas 0.1.17 versijos tapatybės ir prieigos valdymo (IAM) serveris. Jis įgyvendina „OpenID Connect“ ir „OAuth 2.x“ protokolus, yra suderinamas su „Keycloak“ platforma duomenų modelio lygmeniu ir valdo REST API. Įdiegtos funkcijos apima SSO, MFA (TOTP, WebAuthn/passkeys), vartotojų federaciją iš LDAP ir Kerberos/SPNEGO, prisijungimą per išorinius tapatybės teikėjus (OIDC, socialinius tinklus), prisijungimo puslapius su pritaikomu dizainu ir lokalizacija bei deklaratyvią pradinę konfigūraciją iš YAML pirmojo paleidimo metu. Serveris parašytas „Rust“ kalba (nesaugus kodas atributų lygmeniu draudžiamas), platinamas pagal „Apache 2.0“ licenciją ir pateikiamas kaip vienas, savarankiškas dvejetainis failas su integruota administravimo ir vartotojo konsolėmis. Versijos generuojamos šioms platformoms: Linux, Windows и macOS (amd64 ir
ranka64).

Svarbiausias projekto bruožas yra nuolatinis atitikties tikrinimas.
Oficialus „OpenID Foundation Conformance Suite“ (5.3.2) testų rinkinys. Kiekvienos versijos testavimas atliekamas CI aplinkoje izoliuotoje „Docker“ aplinkoje. Modulių rezultatai saugomi saugykloje, o visas ataskaitų paketas pridedamas prie...
Kiekvienas leidimas. Atitiktis „Keycloak“ tikrinama atliekant testų rinkinį. Planuojama oficialiai sertifikuoti.

Dažniausiai dirbtinio intelekto agentų scenarijuose naudojami protokolai yra DPoP (RFC 9449, prieigos rakto susiejimas su turėtojo raktu), prieigos rakto mainai (RFC 8693, privilegijų apribojimas prieigos rakto mainų metu) ir CIBA (apklausos režimas, žmogaus veiksmų patvirtinimas). Taip pat palaikomi PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), dinaminė kliento registracija (RFC 7591/7592) ir įrenginio autorizacija (RFC 8628). Visiškas 100 000 vartotojų importavimas iš MS Active Directory trunka maždaug 30 sekundžių.

Šaltinis: opennet.ru

Pirkite patikimą prieglobą svetainėms su DDoS apsauga, VPS VDS serveriais 🔥 Įsigykite patikimą svetainių talpinimą su DDoS apsauga, VPS VDS serveriais | ProHoster