Bol vydaný server Issuerd 0.1.17 pre správu identít a prístupov (IAM). Implementuje protokoly OpenID Connect a OAuth 2.x a je kompatibilný s platformou Keycloak na úrovni dátového modelu a spravuje REST API. Medzi implementované funkcie patrí SSO, MFA (TOTP, WebAuthn/prístupové kľúče), federácia používateľov z LDAP a Kerberos/SPNEGO, prihlásenie prostredníctvom externých poskytovateľov identít (OIDC, sociálne siete), prihlasovacie stránky s prispôsobiteľným dizajnom a lokalizáciou a deklaratívna počiatočná konfigurácia z YAML pri prvom spustení. Server je napísaný v jazyku Rust (nebezpečný kód je zakázaný na úrovni atribútov), distribuovaný pod licenciou Apache 2.0 a dodáva sa ako jeden samostatný binárny súbor s integrovanou administratívnou konzolou a konzolou pre používateľov. Zostavy sú generované pre nasledujúce platformy: Linux, Windows и macOS (zmena 64 a
rameno64).
Kľúčovou črtou projektu je neustále overovanie súladu.
Oficiálna testovacia sada OpenID Foundation Conformance Suite (5.3.2). Testovanie sa vykonáva v CI pre každé vydanie v izolovanom prostredí Docker. Výsledky modul po module sú uložené v repozitári a kompletný balík správ je priložený k...
Každé vydanie. Parita s Keycloakom je overená súborom testov. Plánuje sa oficiálna certifikácia.
Medzi protokoly bežne používané v scenároch agentov AI patrí DPoP (RFC 9449, viazanie tokenu na kľúč nosiča), výmena tokenov (RFC 8693, obmedzenie privilégií počas výmeny tokenov) a CIBA (režim dotazovania, ľudské potvrdenie akcií). Podporované sú aj PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), dynamická registrácia klientov (RFC 7591/7592) a autorizácia zariadení (RFC 8628). Úplný import 100 000 používateľov z MS Active Directory trvá približne 30 sekúnd.
Zdroj: opennet.ru
