Уязвимость в СУБД SQLite

В СУБД SQLite выявлена уязвимость (CVE-2019-5018), позволяющая выполнить свой код в системе при наличии возможности выполнения SQL-запроса, подготовленного злоумышленником. Проблема вызвана ошибкой в реализации оконных функций и проявляется начиная с ветки SQLite 3.26. Уязвимость устранена в апрельском выпуске SQLite 3.28 без явного упоминания об исправлении проблем с безопасностью.

Специально оформленный SQL-запрос SELECT может привести к обращению к уже освобождённой области памяти (use-after-free), что может потенциально быть использовано для создания эксплоита для выполнения своего кода в контексте приложения, использующего SQLite. Уязвимость может быть эксплуатирована в случае если приложение допускает передачу в SQLite SQL-конструкций, поступающих извне.

Например, потенциально атака может быть совершена на браузер Chrome и приложения, использующие движок Chromium, так как API WebSQL реализован поверх SQLite и обращается к данной СУБД для обработки SQL-запросов из web-приложений. Для атаки достаточно создать страницу с вредоносным JavaScript-кодом и добиться чтобы пользователь открыл её в браузере на базе движка Chromium.

Источник: opennet.ru

Добавить комментарий